summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-16 18:01:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-15 17:07:03 +0100
commit96636e4910870906efb63f9e8890515c142bd941 (patch)
treef53e68c162d22b3c0e324a5fe27f98b3fc388b36
parent977617ac5eec4ab6940bee29e133b8db91f14e1f (diff)
downloadpatches-96636e4910870906efb63f9e8890515c142bd941.tar
patches-96636e4910870906efb63f9e8890515c142bd941.tar.gz
gnu: Add fbset.
* gnu/packages/linux.scm (fbset): New public variable.
-rw-r--r--gnu/packages/linux.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index db1bed04e2..ce8ca8c510 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1229,6 +1229,62 @@ The Discordian calendar was made popular by the \"Illuminatus!\" trilogy
by Robert Shea and Robert Anton Wilson.")
(license license:public-domain)))
+(define-public fbset
+ (package
+ (name "fbset")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://users.telenet.be/geertu/Linux/fbdev/fbset-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "080wnisi0jq7dp0jcwdp83rq8q8s3kw41vc712516xbv4jq4mzs0"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (srfi srfi-26))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-before 'install 'pre-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("mknod ") "true ")
+ ;; The Makefile doesn't honour PREFIX or similar.
+ (("/usr") out))
+ (mkdir out)
+ (with-directory-excursion out
+ (for-each mkdir-p (list "sbin"
+ "man/man5"
+ "man/man8")))
+ #t)))
+ (add-after 'install 'install-fb.modes
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (etc (string-append out "/etc")))
+ (for-each (cut install-file <> etc)
+ (find-files "etc" "^fb\\.modes"))
+ (symlink "fb.modes.ATI"
+ (string-append etc "/fb.modes"))
+ #t))))
+ ;; Parallel building races to create modes.tab.c.
+ #:parallel-build? #f
+ #:tests? #f)) ; no test suite
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)))
+ (home-page "http://users.telenet.be/geertu/Linux/fbdev/")
+ (synopsis "Show and modify Linux frame buffer settings")
+ (description
+ "The kernel Linux's @dfn{frame buffers} provide a simple interface to
+different kinds of graphic displays. The @command{fbset} utility can query and
+change various device settings such as depth, virtual resolution, and timing
+parameters.")
+ (license license:gpl2)))
+
(define-public procps
(package
(name "procps")