summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-15 16:53:21 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-16 22:46:37 +0100
commit8db20f2dddaf25d68564f9999cbe117e3cd19ace (patch)
tree93b0d5a1730d87d2bf79f2b9c9e1d864f2484020
parentce5af131d896f45c088a30d13f62a0914d97829b (diff)
downloadpatches-8db20f2dddaf25d68564f9999cbe117e3cd19ace.tar
patches-8db20f2dddaf25d68564f9999cbe117e3cd19ace.tar.gz
gnu: blender: Update to 2.82.
* gnu/packages/graphics.scm (blender): Update to 2.82. [arguments]: Uncomment ‘fix-broken-import’ phase.
-rw-r--r--gnu/packages/graphics.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index a7ea6192fb..9aa0e134b2 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -88,14 +88,14 @@
(define-public blender
(package
(name "blender")
- (version "2.81a")
+ (version "2.82")
(source (origin
(method url-fetch)
(uri (string-append "https://download.blender.org/source/"
"blender-" version ".tar.xz"))
(sha256
(base32
- "1zl0ar95qkxsrbqw9miz2hrjijlqjl06vg3clfk9rm7krr2l3b2j"))))
+ "0rgw8nilvn6k6r7p28y2l1rwpami1cc8xz473jaahn7wa4ndyah0"))))
(build-system cmake-build-system)
(arguments
(let ((python-version (version-major+minor (package-version python))))
@@ -127,11 +127,11 @@
(modify-phases %standard-phases
;; XXX This file doesn't exist in the Git sources but will probably
;; exist in the eventual 2.80 source tarball.
-; (add-after 'unpack 'fix-broken-import
-; (lambda _
-; (substitute* "release/scripts/addons/io_scene_fbx/json2fbx.py"
-; (("import encode_bin") "from . import encode_bin"))
-; #t))
+ (add-after 'unpack 'fix-broken-import
+ (lambda _
+ (substitute* "release/scripts/addons/io_scene_fbx/json2fbx.py"
+ (("import encode_bin") "from . import encode_bin"))
+ #t))
(add-after 'set-paths 'add-ilmbase-include-path
(lambda* (#:key inputs #:allow-other-keys)
;; OpenEXR propagates ilmbase, but its include files do not appear