summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-24 22:34:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-26 12:19:18 +0300
commit7bc7ffc24339d83e9003bb9bea6fad568bcf0204 (patch)
tree50b64a024ce6795fb65f7b1c13ea2ff491282c00
parent1df790d50d7980d83937bfa93d9b270bcc2b1be8 (diff)
downloadpatches-7bc7ffc24339d83e9003bb9bea6fad568bcf0204.tar
patches-7bc7ffc24339d83e9003bb9bea6fad568bcf0204.tar.gz
gnu: Add x265.
* gnu/packages/video.scm (x265): New variable.
-rw-r--r--gnu/packages/video.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bd82eb8397..68f78847b3 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -250,6 +250,37 @@ H.264 (MPEG-4 AVC) video streams.")
"file://extras/cl.h"
"See extras/cl.h in the distribution.")))))
+(define-public x265
+ (package
+ (name "x265")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.videolan.org/videolan/x265/"
+ "x265_" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hx6sr9l7586gs4qds2sj0i1m5brxkaqq3cwmibhfb559fpvkz48"))
+ (modules '((guix build utils)))
+ (snippet
+ '(delete-file-recursively "source/compat/getopt"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; tests are skipped if cpu-optimized code isn't built
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'prepare-build
+ (lambda _
+ (delete-file-recursively "build")
+ (chdir "source")
+ #t)))))
+ (home-page "http://x265.org/")
+ (synopsis "Library for encoding h.265/HEVC video streams")
+ (description "x265 is a H.265 / HEVC video encoder application library,
+designed to encode video or images into an H.265 / HEVC encoded bitstream.")
+ (license license:gpl2+)))
+
(define-public libass
(package
(name "libass")