summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-16 22:32:37 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-16 22:46:39 +0100
commit3603f5536ee0223f2e15ca6c518ab922030646dd (patch)
tree2879d858b8bb81d2c3a330e46e3d6e0293d4b722
parent2392e589c3b3f7805805c3fce11d208877325970 (diff)
downloadpatches-3603f5536ee0223f2e15ca6c518ab922030646dd.tar
patches-3603f5536ee0223f2e15ca6c518ab922030646dd.tar.gz
gnu: wabt: Use Texinfo mark-up.
* gnu/packages/web.scm (wabt)[description]: Mark up more better.
-rw-r--r--gnu/packages/web.scm25
1 files changed, 15 insertions, 10 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2b9836ecc4..dc67dbd547 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1095,16 +1095,21 @@ for efficient socket-like bidirectional reliable communication channels.")
(description "WABT (pronounced: wabbit) is a suite of tools for
WebAssembly, including:
-* wat2wasm: translate from WebAssembly text format to the WebAssembly binary
- format
-* wasm2wat: the inverse of wat2wasm, translate from the binary format back
- to the text format (also known as a .wat)
-* wasm-objdump: print information about a wasm binary. Similar to objdump.
-* wasm-interp: decode and run a WebAssembly binary file using a stack-based
- interpreter
-* wat-desugar: parse .wat text form as supported by the spec interpreter
- (s-expressions, flat syntax, or mixed) and print canonical flat format
-* wasm2c: convert a WebAssembly binary file to a C source and header
+@enumerate
+@item @command{wat2wasm} translates from WebAssembly text format to the
+WebAssembly binary format
+@item @command{wasm2wat} is the inverse; it translates from the binary format
+back to the text format (also known as a .wat)
+@item @command{wasm-objdump} prints information about a wasm binary, similarly
+to @command{objdump}.
+@item @command{wasm-interp} decodes ands run a WebAssembly binary file using a
+stack-based interpreter
+@item @command{wat-desugar} parses .wat text form as supported by the spec
+interpreter (s-expressions, flat syntax, or mixed) and prints the canonical
+flat format
+@item @command{wasm2c} converts a WebAssembly binary file to a C source and
+header file.
+@end enumerate
These tools are intended for use in (or for development of) toolchains or
other systems that want to manipulate WebAssembly files.")