summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-02-15 13:31:33 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-15 14:43:30 +0100
commit2e5044cfe49de2caf4e4ae2f1be4c2b9f1d690a2 (patch)
treedf303c90c2e40ff0c2f4c22f221845d1a71e515b
parent13c8e747e86e39c0a8c6ec7da8c812d9bbcb682b (diff)
downloadpatches-2e5044cfe49de2caf4e4ae2f1be4c2b9f1d690a2.tar
patches-2e5044cfe49de2caf4e4ae2f1be4c2b9f1d690a2.tar.gz
gnu: monero: Disable core tests.
Core tests sometimes fail at least on i686-linux. Let's disable them for now and just try hash tests and unit tests. * gnu/packages/finance.scm (monero)[arguments]: Don't run 'core_tests' in 'check' phase.
-rw-r--r--gnu/packages/finance.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 990298ce3f..2ba413d388 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -573,7 +573,11 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
;; Only try tests that don't need access to network or system
(replace 'check
(lambda _
- (invoke "make" "ARGS=-R 'hash|core_tests' --verbose" "test")))
+ ;; Core tests sometimes fail, at least on i686-linux.
+ ;; Let's disable them for now and just try hash tests
+ ;; and unit tests.
+ ;; (invoke "make" "ARGS=-R 'hash|core_tests' --verbose" "test")))
+ (invoke "make" "ARGS=-R 'hash' --verbose" "test")))
(add-after 'check 'unit-tests
(lambda _
(let ((excluded-unit-tests