summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-15 21:56:33 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-16 22:46:38 +0100
commit1f14453eedfede4626a78321c66a009c9997bee4 (patch)
tree58edc9fd6c990efc21259f7d55fac611e540eeab
parent8db20f2dddaf25d68564f9999cbe117e3cd19ace (diff)
downloadpatches-1f14453eedfede4626a78321c66a009c9997bee4.tar
patches-1f14453eedfede4626a78321c66a009c9997bee4.tar.gz
gnu: Remove blender@2.79b.
As discussed on #guix with lfam and raingloom, it no longer builds and users with hardware that requires it can use ‘guix time-machine’. * gnu/packages/graphics.scm (blender-2.79): Remove variable.
-rw-r--r--gnu/packages/graphics.scm89
1 files changed, 0 insertions, 89 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9aa0e134b2..f723e00aa4 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -176,95 +176,6 @@ compositing and motion tracking, even video editing and game creation. The
application can be customized via its API for Python scripting.")
(license license:gpl2+)))
-(define-public blender-2.79
- (package
- (name "blender")
- (version "2.79b")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://download.blender.org/source/"
- "blender-" version ".tar.gz"))
- (sha256
- (base32
- "1g4kcdqmf67srzhi3hkdnr4z1ph4h9sza1pahz38mrj998q4r52c"))
- (patches (search-patches "blender-2.79-newer-ffmpeg.patch"
- "blender-2.79-python-3.7-fix.patch"))))
- (build-system cmake-build-system)
- (arguments
- (let ((python-version (version-major+minor (package-version python))))
- `(;; Test files are very large and not included in the release tarball.
- #:tests? #f
- #:configure-flags
- (list "-DWITH_CODEC_FFMPEG=ON"
- "-DWITH_CODEC_SNDFILE=ON"
- "-DWITH_CYCLES=ON"
- "-DWITH_DOC_MANPAGE=ON"
- "-DWITH_FFTW3=ON"
- "-DWITH_GAMEENGINE=ON"
- "-DWITH_IMAGE_OPENJPEG=ON"
- "-DWITH_INPUT_NDOF=ON"
- "-DWITH_INSTALL_PORTABLE=OFF"
- "-DWITH_JACK=ON"
- "-DWITH_MOD_OCEANSIM=ON"
- "-DWITH_PLAYER=ON"
- "-DWITH_PYTHON_INSTALL=OFF"
- "-DWITH_PYTHON_INSTALL=OFF"
- "-DWITH_SYSTEM_OPENJPEG=ON"
- (string-append "-DPYTHON_LIBRARY=python" ,python-version "m")
- (string-append "-DPYTHON_LIBPATH=" (assoc-ref %build-inputs "python")
- "/lib")
- (string-append "-DPYTHON_INCLUDE_DIR=" (assoc-ref %build-inputs "python")
- "/include/python" ,python-version "m")
- (string-append "-DPYTHON_VERSION=" ,python-version))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-broken-import
- (lambda _
- (substitute* "release/scripts/addons/io_scene_fbx/json2fbx.py"
- (("import encode_bin") "from . import encode_bin"))
- #t))
- (add-after 'set-paths 'add-ilmbase-include-path
- (lambda* (#:key inputs #:allow-other-keys)
- ;; OpenEXR propagates ilmbase, but its include files do not appear
- ;; in the CPATH, so we need to add "$ilmbase/include/OpenEXR/" to
- ;; the CPATH to satisfy the dependency on "half.h".
- (setenv "CPATH"
- (string-append (assoc-ref inputs "ilmbase")
- "/include/OpenEXR"
- ":" (or (getenv "CPATH") "")))
- #t))))))
- (inputs
- `(("boost" ,boost)
- ("jemalloc" ,jemalloc)
- ("libx11" ,libx11)
- ("openimageio" ,openimageio-1.7)
- ("openexr" ,openexr)
- ("ilmbase" ,ilmbase)
- ("openjpeg" ,openjpeg-1)
- ("libjpeg" ,libjpeg)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("ffmpeg" ,ffmpeg)
- ("fftw" ,fftw)
- ("jack" ,jack-1)
- ("libsndfile" ,libsndfile)
- ("freetype" ,freetype)
- ("glew" ,glew)
- ("openal" ,openal)
- ("python" ,python)
- ("zlib" ,zlib)))
- (home-page "https://blender.org/")
- (synopsis "3D graphics creation suite")
- (description
- "Blender is a 3D graphics creation suite. It supports the entirety of
-the 3D pipeline—modeling, rigging, animation, simulation, rendering,
-compositing and motion tracking, even video editing and game creation. The
-application can be customized via its API for Python scripting.
-
-NOTE: This older version of Blender is the last release that does not require
-OpenGL 3. It is retained for use with older computers.")
- (license license:gpl2+)))
-
(define-public assimp
(package
(name "assimp")