summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-26 09:58:55 +0100
committerLudovic Courtès <ludo@gnu.org>2015-10-27 00:01:20 +0100
commit5e1c936712d824e7ccbb3cbb8ac7ffa375237469 (patch)
tree6e784e6b39025c689db8eb3fbed8cd34f53a5acd
parente3e1ecf67c03836295b513d10403194a513afa2d (diff)
downloadpatches-5e1c936712d824e7ccbb3cbb8ac7ffa375237469.tar
patches-5e1c936712d824e7ccbb3cbb8ac7ffa375237469.tar.gz
gnu: Add python-file.
* gnu/packages/python.scm (python-file, python2-file): New variables.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9721343235..23150a3dfe 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages backup)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages file)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gdbm)
#:use-module (gnu packages gcc)
@@ -5750,3 +5751,29 @@ Python's @code{ctypes} foreign function interface (FFI).")
(define-public python2-libarchive-c
(package-with-python2 python-libarchive-c))
+
+(define-public python-file
+ (package
+ (inherit file)
+ (name "python-file")
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f ;no tests
+ #:phases (modify-phases %standard-phases
+ (add-before 'build 'change-directory
+ (lambda _
+ (chdir "python")
+ #t))
+ (add-before 'build 'set-library-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((file (assoc-ref inputs "file")))
+ (substitute* "magic.py"
+ (("find_library\\('magic'\\)")
+ (string-append "'" file "/lib/libmagic.so'")))
+ #t))))))
+ (inputs `(("file" ,file)))
+ (self-native-input? #f)
+ (synopsis "Python bindings to the libmagic file type guesser")))
+
+(define-public python2-file
+ (package-with-python2 python-file))