summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-02-12 17:04:27 -0500
committerLeo Famulari <leo@famulari.name>2020-02-13 19:44:27 -0500
commita726d91d0cdbf3d0422c8ca21b70403ce458dadc (patch)
tree6e8431e0db66bccb3b283f6dbe2681c684241652
parent3170d7546626d9342f58416ea6a31f0fa3f00268 (diff)
downloadpatches-a726d91d0cdbf3d0422c8ca21b70403ce458dadc.tar
patches-a726d91d0cdbf3d0422c8ca21b70403ce458dadc.tar.gz
gnu: Move go-github-com-golang-protobuf-proto to the Golang module.
* gnu/packages/syncthing.scm (go-github-com-golang-protobuf-proto): Move variable ... gnu/packages/golang.scm (go-github-com-golang-protobuf-proto): ... to here.
-rw-r--r--gnu/packages/golang.scm27
-rw-r--r--gnu/packages/syncthing.scm25
2 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1461324c8f..9150d66f99 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2016 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2016, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 Petter <petter@mykolab.ch>
-;;; Copyright © 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Sergei Trofimovich <slyfox@inbox.ru>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -3222,3 +3222,28 @@ optimized for humans, JUnit XML for CI integration, and a summary of the
test results.")
(home-page "https://github.com/gotestyourself/gotestsum")
(license license:asl2.0)))
+
+(define-public go-github-com-golang-protobuf-proto
+ (package
+ (name "go-github-com-golang-protobuf-proto")
+ (version "1.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golang/protobuf.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15am4s4646qy6iv0g3kkqq52rzykqjhm4bf08dk0fy2r58knpsyl"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/golang/protobuf/proto"
+ #:unpack-path "github.com/golang/protobuf"
+ ;; Requires unpackaged golang.org/x/sync/errgroup
+ #:tests? #f))
+ (synopsis "Go support for Protocol Buffers")
+ (description "This package provides Go support for the Protocol Buffers
+data serialization format.")
+ (home-page "https://github.com/golang/protobuf")
+ (license license:bsd-3)))
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 099ad3e826..9bda6dd765 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -761,31 +761,6 @@ bounds.")
(home-page "https://github.com/beorn7/perks")
(license expat))))
-(define-public go-github-com-golang-protobuf-proto
- (package
- (name "go-github-com-golang-protobuf-proto")
- (version "1.3.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/golang/protobuf.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "15am4s4646qy6iv0g3kkqq52rzykqjhm4bf08dk0fy2r58knpsyl"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/golang/protobuf/proto"
- #:unpack-path "github.com/golang/protobuf"
- #:tests? #f ; requires unpackaged golang.org/x/sync/errgroup
- ))
- (synopsis "Go support for Protocol Buffers")
- (description "This package provides Go support for the Protocol Buffers
-data serialization format.")
- (home-page "https://github.com/golang/protobuf")
- (license bsd-3)))
-
(define-public go-github-com-prometheus-client-model
(let ((commit "14fe0d1b01d4d5fc031dd4bec1823bd3ebbe8016")
(revision "2"))