summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-02-12 23:56:35 -0500
committerLeo Famulari <leo@famulari.name>2020-02-13 19:44:31 -0500
commit9c2eb9622d1ae3d684a58a7f0ecd38952b0da502 (patch)
treeb993eccd259af481ee1ac3d0a300f91b2557766a
parent05b8096dd2d02d251c68b37e6d730c1f9c88c00b (diff)
downloadpatches-9c2eb9622d1ae3d684a58a7f0ecd38952b0da502.tar
patches-9c2eb9622d1ae3d684a58a7f0ecd38952b0da502.tar.gz
gnu: Add go-github-com-cespare-xxhash.
* gnu/packages/syncthing.scm (go-github-com-cespare-xxhash): New variable.
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 6e6110438a..10f5e59ebc 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Petter <petter@mykolab.ch>
-;;; Copyright © 2016, 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1056,3 +1056,25 @@ virtual connections from a single physical connection.")
and RFC 5389).")
(home-page "https://github.com/ccding/go-stun")
(license asl2.0))))
+
+(define-public go-github-com-cespare-xxhash
+ (package
+ (name "go-github-com-cespare-xxhash")
+ (version "2.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cespare/xxhash")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12ad3z7ki9j07c4kx3ywkl6188i2afsjg7sl60wd21p6zkkpfjxq"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/cespare/xxhash"))
+ (synopsis "Go implementation of xxHash")
+ (description "This package provides of Go implementation of the 64-bit
+xxHash algorithm (XXH64).")
+ (home-page "https://github.com/cespare/xxhash/")
+ (license expat)))