summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-02-13 13:49:09 +0100
committerJelle Licht <jlicht@fsfe.org>2020-02-14 16:33:17 +0100
commit96945cabe038cd02c2d76e8821d264626fcc999a (patch)
tree27e58422b48374d9250282653b30f96ad5866817
parent98e3953e96d1f172e2e44d1f2d2f2e6b107f2daa (diff)
downloadpatches-96945cabe038cd02c2d76e8821d264626fcc999a.tar
patches-96945cabe038cd02c2d76e8821d264626fcc999a.tar.gz
gnu: Add haproxy.
* gnu/packages/networking.scm (haproxy): New variable.
-rw-r--r--gnu/packages/networking.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index e8ad57e8ae..dbc40028ad 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2019 Daniel Schaefer <git@danielschaefer.me>
;;; Copyright © 2019 Diego N. Barbato <dnbarbato@posteo.de>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -65,6 +66,7 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages adns)
@@ -2891,3 +2893,46 @@ cables.")
(license:non-copyleft ; slirpvde
"file://COPYING.slirpvde"
"See COPYING.slirpvde in the distribution.")))))
+
+(define-public haproxy
+ (package
+ (name "haproxy")
+ (version "2.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.haproxy.org/download/"
+ (version-major+minor version)
+ "/src/haproxy-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0n8bw3d6gikr8c56ycrvksp1sl0b4yfzp19867cxkl3l0daqwrxv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (let* ((out (assoc-ref %outputs "out")))
+ (list (string-append "PREFIX=" out)
+ (string-append "DOCDIR=" out "/share/" ,name)
+ "TARGET=linux-glibc"
+ "USE_LUA=1"
+ "USE_OPENSSL=1"
+ "USE_ZLIB=1"
+ "USE_PCRE_2=1"))
+ #:tests? #f ; there are only regression tests, using varnishtest
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("lua" ,lua)
+ ("openssl" ,openssl)
+ ("pcre2" ,pcre2)
+ ("zlib" ,zlib)))
+ (home-page "https://www.haproxy.org/")
+ (synopsis "Reliable, high performance TCP/HTTP load balancer")
+ (description "HAProxy is a free, very fast and reliable solution offering
+high availability, load balancing, and proxying for TCP and HTTP-based
+applications. It is particularly suited for web sites crawling under very
+high loads while needing persistence or Layer7 processing. Supporting tens of
+thousands of connections is clearly realistic with today's hardware.")
+ (license (list license:gpl2+
+ license:lgpl2.1
+ license:lgpl2.1+))))