summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-02-12 21:32:07 -0500
committerLeo Famulari <leo@famulari.name>2020-02-13 19:44:28 -0500
commit726727e163a0fc9401c886e27c1c4ca892b6efa2 (patch)
treedc25a10c11ad031116318dcf2f3ffc0498f3fa6e
parent195960737c73e69d027c3d73a321d2b5adbb96ff (diff)
downloadpatches-726727e163a0fc9401c886e27c1c4ca892b6efa2.tar
patches-726727e163a0fc9401c886e27c1c4ca892b6efa2.tar.gz
gnu: go-github-com-pkg-errors: Update to 0.9.0.
* gnu/packages/golang.scm (go-github-com-pkg-errors): Update to 0.9.0.
-rw-r--r--gnu/packages/golang.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c17c605229..fd676f0991 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2936,28 +2936,26 @@ network protocol.")
(license license:expat)))
(define-public go-github-com-pkg-errors
- (let ((commit "27936f6d90f9c8e1145f11ed52ffffbfdb9e0af7")
- (revision "0"))
- (package
- (name "go-github-com-pkg-errors")
- (version (git-version "0.8.1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pkg/errors.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0yzmgi6g4ak4q8y7w6x0n5cbinlcn8yc3gwgzy4yck00qdn25d6y"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/pkg/errors"))
- (synopsis "Go error handling primitives")
- (description "This package provides @code{error}, which offers simple
+ (package
+ (name "go-github-com-pkg-errors")
+ (version "0.9.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pkg/errors.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hlivqlcnm9wrj0v7h43gamw7mvg6svz9sm31fx28zn4ll25ablh"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/pkg/errors"))
+ (synopsis "Go error handling primitives")
+ (description "This package provides @code{error}, which offers simple
error handling primitives in Go.")
- (home-page "https://github.com/pkg/errors")
- (license license:bsd-2))))
+ (home-page "https://github.com/pkg/errors")
+ (license license:bsd-2)))
(define-public go-github-com-maruel-panicparse
(package