summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-02-12 21:37:27 -0500
committerLeo Famulari <leo@famulari.name>2020-02-13 19:44:28 -0500
commit6ac3b835d10cb649b216ced86c14595d94354c77 (patch)
tree07fd90352fb4ab2b45ac9457934ce55dedbe4200
parent726727e163a0fc9401c886e27c1c4ca892b6efa2 (diff)
downloadpatches-6ac3b835d10cb649b216ced86c14595d94354c77.tar
patches-6ac3b835d10cb649b216ced86c14595d94354c77.tar.gz
gnu: Change upstream for the go-nat-pmp Go NAT-PMP client.
* gnu/packages/syncthing.scm (go-github-com-audriusbutkevicius-go-nat-pmp): Replace with ... (go-github-com-jackpal-go-nat-pmp): ... new package. (syncthing)[inputs]: Adjust accordingly.
-rw-r--r--gnu/packages/syncthing.scm45
1 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 6f5025184c..d9e7f522b5 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -52,8 +52,8 @@
;; When updating Syncthing, check 'go.mod' in the source distribution to
;; ensure we are using the correct versions of these dependencies.
(inputs
- `(("go-github-com-audriusbutkevicius-go-nat-pmp"
- ,go-github-com-audriusbutkevicius-go-nat-pmp)
+ `(("go-github-com-jackpal-go-nat-pmp"
+ ,go-github-com-jackpal-go-nat-pmp)
("go-github-com-bkaradzic-go-lz4" ,go-github-com-bkaradzic-go-lz4)
("go-github-com-calmh-xdr" ,go-github-com-calmh-xdr)
("go-github-com-chmduquesne-rollinghash"
@@ -163,29 +163,28 @@ Protocol.")
(home-page "https://github.com/syncthing/syncthing")
(license mpl2.0)))
-(define-public go-github-com-audriusbutkevicius-go-nat-pmp
- (let ((commit "452c97607362b2ab5a7839b8d1704f0396b640ca")
- (revision "0"))
- (package
- (name "go-github-com-audriusbutkevicius-go-nat-pmp")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/AudriusButkevicius/go-nat-pmp")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1accmpl1llk16a19nlyy991fqrgfay6l53gb64hgmdfmqljdvbk7"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/AudriusButkevicius/go-nat-pmp"))
- (synopsis "Port mapping and discovery of external IP address")
- (description "This package provides a Go client for the NAT-PMP internet
+(define-public go-github-com-jackpal-go-nat-pmp
+ (package
+ (name "go-github-com-jackpal-go-nat-pmp")
+ (version "1.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jackpal/go-nat-pmp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1p2yrzfbkazc9nisr2iqjwzhb6q16zj6finyxxn2ikk7iiighl1g"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/jackpal/go-nat-pmp"))
+ (synopsis "Port mapping and discovery of external IP address")
+ (description "This package provides a Go client for the NAT-PMP internet
protocol for port mapping and discovering the external IP address of a
firewall.")
- (home-page "https://github.com/AudriusButkevicius/go-nat-pmp")
- (license asl2.0))))
+ (home-page "https://github.com/jackpal/go-nat-pmp")
+ (license asl2.0)))
(define-public go-github-com-audriusbutkevicius-recli
(package