summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-02-13 16:55:40 -0500
committerLeo Famulari <leo@famulari.name>2020-02-13 19:44:29 -0500
commit47a4a6da5e45f5fb98bcc7502de71b5abe848027 (patch)
tree0ccb0eb618078cc7d703d042d6c58e4539589ab3
parent3c06b06034ccd407a7ab696ab087f033b5a8286e (diff)
downloadpatches-47a4a6da5e45f5fb98bcc7502de71b5abe848027.tar
patches-47a4a6da5e45f5fb98bcc7502de71b5abe848027.tar.gz
gnu: Add go-github-com-shurcool-sanitized-anchor-name.
* gnu/packages/golang.scm (go-github-com-shurcool-sanitized-anchor-name): New variable.
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 56dcd0a1d0..33ef90394d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2490,6 +2490,29 @@ building command line apps in Go. The goal is to enable developers to write
fast and distributable command line applications in an expressive way.")
(license license:expat)))
+(define-public go-github-com-shurcool-sanitized-anchor-name
+ (package
+ (name "go-github-com-shurcool-sanitized-anchor-name")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shurcooL/sanitized_anchor_name")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gv9p2nr46z80dnfjsklc6zxbgk96349sdsxjz05f3z6wb6m5l8f"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/shurcooL/sanitized_anchor_name"))
+ (home-page "https://github.com/shurcooL/sanitized_anchor_name")
+ (synopsis "Create sanitized anchor names")
+ (description "This package provides a Go program for creating sanitized
+anchor names.")
+ (license license:expat)))
+
(define-public go-github-com-pmezard-go-difflib
(package
(name "go-github-com-pmezard-go-difflib")