summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-02-13 16:54:04 -0500
committerLeo Famulari <leo@famulari.name>2020-02-13 19:44:29 -0500
commit3c06b06034ccd407a7ab696ab087f033b5a8286e (patch)
treeac1bf51136f04f98e1e2cc0008fd2c302db4c731
parentdf14a8b67d9ca0810e3a6f1cb28db030ae44afd4 (diff)
downloadpatches-3c06b06034ccd407a7ab696ab087f033b5a8286e.tar
patches-3c06b06034ccd407a7ab696ab087f033b5a8286e.tar.gz
gnu: Add go-github-com-pmezard-go-difflib.
* gnu/packages/golang.scm (go-github-com-pmezard-go-difflib): New variable.
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7af663da04..56dcd0a1d0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2490,6 +2490,28 @@ building command line apps in Go. The goal is to enable developers to write
fast and distributable command line applications in an expressive way.")
(license license:expat)))
+(define-public go-github-com-pmezard-go-difflib
+ (package
+ (name "go-github-com-pmezard-go-difflib")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pmezard/go-difflib")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0c1cn55m4rypmscgf0rrb88pn58j3ysvc2d0432dp3c6fqg6cnzw"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/pmezard/go-difflib/difflib"
+ #:unpack-path "github.com/pmezard/go-difflib/"))
+ (home-page "https://github.com/pmezard/go-difflib")
+ (synopsis "Go diff implementation")
+ (description "This package provides unified and context-aware diffs in Go.")
+ (license license:bsd-3)))
+
(define-public go-github-com-whyrusleeping-json-filter
(let ((commit "ff25329a9528f01c5175414f16cc0a6a162a5b8b")
(revision "0"))