summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-01-30 14:54:28 -0500
committerLeo Famulari <leo@famulari.name>2020-02-13 20:13:10 -0500
commit1ce2467fd6d5f8da259be1c7609702814c716702 (patch)
treefafd1533181f891b94a25c85bf67a4b5fc5f2ba1
parentb96aca92554f65096221f8d5bb4ba89c74f4c4b2 (diff)
downloadpatches-1ce2467fd6d5f8da259be1c7609702814c716702.tar
patches-1ce2467fd6d5f8da259be1c7609702814c716702.tar.gz
gnu: LibreOffice: Update to 6.4.0.3.
* gnu/packages/libreoffice.scm (libreoffice): Update to 6.4.0.3. [inputs]: Add qrcodegen-cpp. [source]: Remove obsolete patches and substitutions. * gnu/packages/patches/libreoffice-glm.patch, gnu/packages/patches/libreoffice-icu.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/libreoffice.scm16
-rw-r--r--gnu/packages/patches/libreoffice-glm.patch58
-rw-r--r--gnu/packages/patches/libreoffice-icu.patch126
4 files changed, 4 insertions, 198 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2bbb41da92..9a316f6edb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1113,8 +1113,6 @@ dist_patch_DATA = \
%D%/packages/patches/libmpeg2-global-symbol-test.patch \
%D%/packages/patches/libmygpo-qt-fix-qt-5.11.patch \
%D%/packages/patches/libmygpo-qt-missing-qt5-modules.patch \
- %D%/packages/patches/libreoffice-icu.patch \
- %D%/packages/patches/libreoffice-glm.patch \
%D%/packages/patches/libseccomp-open-aarch64.patch \
%D%/packages/patches/libsndfile-armhf-type-checks.patch \
%D%/packages/patches/libsndfile-CVE-2017-8361-8363-8365.patch \
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 581f098524..539ada46e5 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -41,6 +41,7 @@
#:use-module (guix utils)
#:use-module (ice-9 match)
#:use-module (gnu packages)
+ #:use-module (gnu packages aidc)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
@@ -930,7 +931,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(define-public libreoffice
(package
(name "libreoffice")
- (version "6.3.4.2")
+ (version "6.4.0.3")
(source
(origin
(method url-fetch)
@@ -940,17 +941,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(version-prefix version 3) "/libreoffice-" version ".tar.xz"))
(sha256
(base32
- "1774vmf3lr5x24ikpn1z5vqcdwrhiwfkjy7sx09jqkvpm6d5awnb"))
- (patches (search-patches "libreoffice-icu.patch"
- "libreoffice-glm.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (for-each (lambda (file)
- ;; Adjust to renamed function in Poppler 0.72.
- (substitute* file (("getCString") "c_str")))
- (find-files "sdext/source/pdfimport/xpdfwrapper"))
- #t))))
+ "09ra8a3ylb08xhy8wy233fs0f87klkpsbi9n3zss0c688afxjcf5"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("bison" ,bison)
@@ -1023,6 +1014,7 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
("postgresql" ,postgresql)
("python" ,python)
("python-lxml" ,python-lxml)
+ ("qrcodegen-cpp" ,qrcodegen-cpp)
("redland" ,redland)
("sane-backends" ,sane-backends)
("unixodbc" ,unixodbc)
diff --git a/gnu/packages/patches/libreoffice-glm.patch b/gnu/packages/patches/libreoffice-glm.patch
deleted file mode 100644
index 9e76cf1389..0000000000
--- a/gnu/packages/patches/libreoffice-glm.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-Fix build with GLM 0.9.9.
-
-This patch is an amalgamation of these upstream commits:
-
-https://github.com/LibreOffice/core/commit/953c4add8fd76d88f49a81ae4c21a1fdcc007e57
-https://github.com/LibreOffice/core/commit/5f1bf6598b5725ad1e50ae9f7ec7524cc8a834fa
-
-diff --git a/chart2/Library_chartcore.mk b/chart2/Library_chartcore.mk
-index 28bc87b89057..69d4c0552636 100644
---- a/chart2/Library_chartcore.mk
-+++ b/chart2/Library_chartcore.mk
-@@ -23,6 +23,12 @@ $(eval $(call gb_Library_add_defs,chartcore,\
- -DOOO_DLLIMPLEMENTATION_CHARTVIEW \
- ))
-
-+ifeq ($(SYSTEM_GLM),TRUE)
-+$(eval $(call gb_Library_add_defs,chartcore,\
-+ -DGLM_ENABLE_EXPERIMENTAL \
-+))
-+endif
-+
- $(eval $(call gb_Library_set_precompiled_header,chartcore,$(SRCDIR)/chart2/inc/pch/precompiled_chartcore))
-
- $(eval $(call gb_Library_use_externals,chartcore,\
-diff --git a/vcl/Library_vcl.mk b/vcl/Library_vcl.mk
-index c1f3cc5324e7..0b684c6185a9 100644
---- a/vcl/Library_vcl.mk
-+++ b/vcl/Library_vcl.mk
-@@ -49,6 +49,12 @@ $(eval $(call gb_Library_add_defs,vcl,\
- -DENABLE_MERGELIBS=$(if $(MERGELIBS),1,0) \
- ))
-
-+ifeq ($(SYSTEM_GLM),TRUE)
-+$(eval $(call gb_Library_add_defs,vcl,\
-+ -DGLM_ENABLE_EXPERIMENTAL \
-+))
-+endif
-+
- $(eval $(call gb_Library_use_sdk_api,vcl))
-
- $(eval $(call gb_Library_use_custom_headers,vcl,\
-diff --git a/vcl/Executable_icontest.mk b/vcl/Executable_icontest.mk
-index ce163303f8a4..8c917b71cd0e 100644
---- a/vcl/Executable_icontest.mk
-+++ b/vcl/Executable_icontest.mk
-@@ -19,6 +19,12 @@ $(eval $(call gb_Executable_use_externals,icontest,\
- ))
- endif
-
-+ifeq ($(SYSTEM_GLM),TRUE)
-+$(eval $(call gb_Executable_add_defs,icontest,\
-+ -DGLM_ENABLE_EXPERIMENTAL \
-+))
-+endif
-+
- $(eval $(call gb_Executable_use_api,icontest,\
- offapi \
- udkapi \
diff --git a/gnu/packages/patches/libreoffice-icu.patch b/gnu/packages/patches/libreoffice-icu.patch
deleted file mode 100644
index 2985d564aa..0000000000
--- a/gnu/packages/patches/libreoffice-icu.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-This patch fixes the build of Libreoffice 6.0.5 with icu 61.1.
-It was downloaded from https://bugs.gentoo.org/651702.
-
---- a/forms/source/xforms/datatypes.hxx
-+++ a/forms/source/xforms/datatypes.hxx
-@@ -36,6 +36,8 @@
-
- #include <memory>
-
-+using icu::RegexMatcher;
-+
-
- namespace xforms
- {
---- a/i18npool/inc/collator_unicode.hxx
-+++ a/i18npool/inc/collator_unicode.hxx
-@@ -26,6 +26,8 @@
-
- #include <unicode/tblcoll.h>
-
-+using icu::RuleBasedCollator;
-+
- // ----------------------------------------------------
- // class Collator_Unicode
- // ----------------------------------------------------
---- a/i18npool/source/breakiterator/breakiterator_unicode.cxx
-+++ a/i18npool/source/breakiterator/breakiterator_unicode.cxx
-@@ -30,6 +30,9 @@
- #include <rtl/ustring.hxx>
- #include <string.h>
-
-+using icu::BreakIterator;
-+using icu::RuleBasedBreakIterator;
-+
- U_CDECL_BEGIN
- extern const char OpenOffice_dat[];
- U_CDECL_END
---- a/i18npool/source/collator/collator_unicode.cxx
-+++ a/i18npool/source/collator/collator_unicode.cxx
-@@ -29,6 +29,8 @@
- #include <com/sun/star/i18n/CollatorOptions.hpp>
- #include <cppuhelper/supportsservice.hxx>
-
-+using icu::Collator;
-+
- using namespace ::com::sun::star;
- using namespace ::com::sun::star::i18n;
- using namespace ::com::sun::star::lang;
---- a/i18npool/source/collator/gencoll_rule.cxx
-+++ a/i18npool/source/collator/gencoll_rule.cxx
-@@ -31,6 +31,8 @@
-
- #include <unicode/tblcoll.h>
-
-+using icu::RuleBasedCollator;
-+
- /* Main Procedure */
-
- void data_write(char* file, char* name, sal_uInt8 *data, sal_Int32 len)
---- a/i18npool/source/ordinalsuffix/ordinalsuffix.cxx
-+++ a/i18npool/source/ordinalsuffix/ordinalsuffix.cxx
-@@ -29,6 +29,8 @@
- #include <unicode/normlzr.h>
- #include <memory>
-
-+using icu::NumberFormat;
-+
- using namespace ::com::sun::star::i18n;
- using namespace ::com::sun::star::uno;
- using namespace ::com::sun::star;
---- a/i18npool/source/transliteration/ignoreDiacritics_CTL.cxx
-+++ a/i18npool/source/transliteration/ignoreDiacritics_CTL.cxx
-@@ -12,6 +12,8 @@
- #include <unicode/translit.h>
- #include <unicode/uchar.h>
-
-+using icu::UnicodeString;
-+
- namespace i18npool {
-
- ignoreDiacritics_CTL::ignoreDiacritics_CTL()
---- a/i18nutil/source/utility/unicode.cxx
-+++ a/i18nutil/source/utility/unicode.cxx
-@@ -34,6 +34,9 @@
- // which (obviously) breaks UnicodeType::CURRENCY_SYMBOL
- #undef CURRENCY_SYMBOL
-
-+using icu::NumberFormat;
-+using icu::UnicodeString;
-+
- using namespace ::com::sun::star::i18n;
-
- template<class L, typename T>
---- a/lotuswordpro/source/filter/localtime.cxx
-+++ a/lotuswordpro/source/filter/localtime.cxx
-@@ -57,6 +57,8 @@
- #include <limits.h>
- #include <unicode/timezone.h>
-
-+using icu::TimeZone;
-+
- const long DAY_SEC =24 * 60 * 60;
- const long YEAR_SEC = 365 * DAY_SEC;
- const long FOURYEAR_SEC = 4 * YEAR_SEC + DAY_SEC;
---- a/opencl/source/openclconfig.cxx
-+++ a/opencl/source/openclconfig.cxx
-@@ -17,6 +17,8 @@
- #include <sal/log.hxx>
- #include <sal/types.h>
-
-+using icu::RegexMatcher;
-+
- OpenCLConfig::OpenCLConfig() :
- mbUseOpenCL(true)
- {
---- a/vcl/inc/scrptrun.h
-+++ a/vcl/inc/scrptrun.h
-@@ -45,6 +45,8 @@
- #include <unicode/uscript.h>
- #include <vector>
-
-+using icu::UObject;
-+
- namespace vcl {
-
- struct ParenStackEntry