summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-02-12 22:40:35 -0500
committerLeo Famulari <leo@famulari.name>2020-02-13 19:44:31 -0500
commit05b8096dd2d02d251c68b37e6d730c1f9c88c00b (patch)
treecab11dd0b35d496313e36ac3b28ad72d77f9ac6f
parent199f1be3a3848159c3cb373d6cb62f48ea8a170e (diff)
downloadpatches-05b8096dd2d02d251c68b37e6d730c1f9c88c00b.tar
patches-05b8096dd2d02d251c68b37e6d730c1f9c88c00b.tar.gz
gnu: go-github-com-lucas-clemente-quic-go: Update to 0.12.1.
* gnu/packages/golang.scm (go-github-com-lucas-clemente-quic-go): Update to 0.12.1. [propagated-inputs]: Add go-github-com-golang-protobuf-proto.
-rw-r--r--gnu/packages/golang.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5aeab1fe8c..d165ccf065 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3013,7 +3013,7 @@ implementation of generics.")
(define-public go-github-com-lucas-clemente-quic-go
(package
(name "go-github-com-lucas-clemente-quic-go")
- (version "0.11.2")
+ (version "0.12.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3022,7 +3022,7 @@ implementation of generics.")
(file-name (git-file-name name version))
(sha256
(base32
- "0gqm5mc8alg84ra7yxach34il1jvcij8f76qdqcahnd3d2nhjbia"))))
+ "156nhq4dvw7mr08j952248v81q7702phbn4mp228319sahnbv65h"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/lucas-clemente/quic-go"
@@ -3031,7 +3031,8 @@ implementation of generics.")
(propagated-inputs
`(("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
("go-github-com-cheekybits-genny" ,go-github-com-cheekybits-genny)
- ("go-github-com-marten-seemann-qtls" ,go-github-com-marten-seemann-qtls)))
+ ("go-github-com-marten-seemann-qtls" ,go-github-com-marten-seemann-qtls)
+ ("go-github-com-golang-protobuf-proto" ,go-github-com-golang-protobuf-proto)))
(synopsis "QUIC in Go")
(description "This package provides a Go language implementation of the QUIC
network protocol.")