summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-16 17:32:03 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-12 21:32:19 +0200
commitcf20f8a58257ed5a99a366427da2f5e12beef6aa (patch)
treee56108f387eb6882ab6900a24ab1a0a552ad6cda
parent897a409af205ff41099fa3b60ba5624ecf4d5336 (diff)
downloadpatches-cf20f8a58257ed5a99a366427da2f5e12beef6aa.tar
patches-cf20f8a58257ed5a99a366427da2f5e12beef6aa.tar.gz
gnu: Add rust-malloc-buf-0.
* gnu/packages/crates-io.scm (rust-malloc-buf-0): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a5c9aa4917..d9cc522af6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6750,6 +6750,28 @@ implementation of LZMA and xz stream encoding/decoding.")
platform-independently.")
(license license:expat)))
+(define-public rust-malloc-buf-0.0
+ (package
+ (name "rust-malloc-buf")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "malloc-buf" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jqr77j89pwszv51fmnknzvd53i1nkmcr8rjrvcxhm4dx1zr1fv2"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-libc" ,rust-libc-0.2))))
+ (home-page "https://github.com/SSheldon/malloc_buf")
+ (synopsis "Structs for handling malloc'd memory passed to Rust")
+ (description
+ "This package provides structs for handling malloc'd memory passed to Rust.")
+ (license license:expat)))
+
(define-public rust-maplit-1.0
(package
(name "rust-maplit")