summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-12 01:29:12 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-12 05:00:45 +0100
commitc57c648bfd948dd5478d76e37cf0d74be81a0020 (patch)
treed6c77f02d829bcd831e2346ae7962254bdc3221b
parent330e2796bea9f3c711f7ce0eb805105cea9ece6e (diff)
downloadpatches-c57c648bfd948dd5478d76e37cf0d74be81a0020.tar
patches-c57c648bfd948dd5478d76e37cf0d74be81a0020.tar.gz
gnu: rsnapshot: Update to 1.4.3.
* gnu/packages/backup.scm (rsnapshot): Update to 1.4.3. [arguments]: Disable broken test.
-rw-r--r--gnu/packages/backup.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 0549e94d70..00a7bcc70f 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -423,7 +423,7 @@ rdiff-backup is easy to use and settings have sensible defaults.")
(define-public rsnapshot
(package
(name "rsnapshot")
- (version "1.4.2")
+ (version "1.4.3")
(source
(origin
(method url-fetch)
@@ -431,8 +431,7 @@ rdiff-backup is easy to use and settings have sensible defaults.")
"https://github.com/rsnapshot/rsnapshot/releases/download/"
version "/rsnapshot-" version ".tar.gz"))
(sha256
- (base32
- "05jfy99a0xs6lvsjfp3wz21z0myqhmwl2grn3jr9clijbg282ah4"))))
+ (base32 "1lavqmmsf53pim0nvming7fkng6p0nk2a51k2c2jdq0l7snpl31b"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -444,6 +443,10 @@ rdiff-backup is easy to use and settings have sensible defaults.")
"t/backup_exec/conf/backup_exec.conf")
(("/bin/true") (which "true"))
(("/bin/false") (which "false")))
+
+ ;; Disable a test that tries to connect to localhost on port 22.
+ (delete-file "t/ssh_args/ssh_args.t.in")
+
(invoke "make" "test"))))))
(inputs
`(("perl" ,perl)