summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-26 05:03:22 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-26 05:03:22 +0100
commitcb723be5b98a57ae4f909022d1ce2b5d3bcdaabf (patch)
tree2e97e389f9fea3963b621f475ae1cb7ebc125090
parent71a2d4176bdf7d88fd9d342b95ae74ed9685ec8d (diff)
downloadpatches-cb723be5b98a57ae4f909022d1ce2b5d3bcdaabf.tar
patches-cb723be5b98a57ae4f909022d1ce2b5d3bcdaabf.tar.gz
gnu: python-scandir: Run the test suite.
* gnu/packages/python.scm (python-scandir)[arguments]: Replace CHECK-PHASE.
-rw-r--r--gnu/packages/python.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 64f48fd352..4946d9afd7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11091,6 +11091,11 @@ It supports both normal and Unicode strings.")
(sha256
(base32 "0gbnhjzg42rj87ljv9kb648rfxph69ly3c8r9841dxy4d7l5pmdj"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "test/run_tests.py"))))))
(home-page "https://github.com/benhoyt/scandir")
(synopsis "Directory iteration function")
(description