summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-02-07 22:03:42 -0600
committerLudovic Courtès <ludo@gnu.org>2019-02-12 23:30:17 +0100
commitbe4d840cca92bc40a7fcadd69b5017597554683d (patch)
tree2542e16799936bff1f4f11d4185d98b9c1ae4604
parent56f4ad47bde0f416b31433a8274e301ceda4bf42 (diff)
downloadpatches-be4d840cca92bc40a7fcadd69b5017597554683d.tar
patches-be4d840cca92bc40a7fcadd69b5017597554683d.tar.gz
gnu: Add python-language-server.
* gnu/packages/python-xyz.scm (python-language-server): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 55d2c26d45..55ac37ffb0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2624,6 +2624,38 @@ Language (TOML) configuration files.")
Server (PLS).")
(license license:expat)))
+(define-public python-language-server
+ (package
+ (name "python-language-server")
+ (version "0.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-language-server" version))
+ (sha256
+ (base32
+ "04pbxl06hg0ddm2xx99jn9jh40yv0mmzdjw8pqd2rbcdg42hhia6"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pluggy" ,python-pluggy)
+ ("python-jsonrpc-server" ,python-jsonrpc-server)
+ ("python-jedi" ,python-jedi)
+ ("python-yapf" ,python-yapf)
+ ("python-pyflakes" ,python-pyflakes)
+ ("python-pydocstyle" ,python-pydocstyle)
+ ("python-pycodestyle" ,python-pycodestyle)
+ ("python-mccabe" ,python-mccabe)
+ ("python-rope" ,python-rope)
+ ("python-autopep8" ,python-autopep8)))
+ (home-page "https://github.com/palantir/python-language-server")
+ (synopsis "Python implementation of the Language Server Protocol")
+ (description
+ "The Python Language Server (pyls) is an implementation of the Python 3
+language specification for the Language Server Protocol (LSP). This tool is
+used in text editing environments to provide a complete and integrated
+feature-set for programming Python effectively.")
+ (license license:expat)))
+
(define-public python-black
(package
(name "python-black")