summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-31 18:56:44 -0400
committerLeo Famulari <leo@famulari.name>2017-08-01 01:02:53 -0400
commit3d0fbd3c2f92cee74fd443eb5c252b8dd9b75b43 (patch)
treed2939f3a0c71d33bbc3f3b924085b825283533f1
parentbefb2c0e6e17ce224586e9c2380f0470a5bef1c8 (diff)
downloadpatches-3d0fbd3c2f92cee74fd443eb5c252b8dd9b75b43.tar
patches-3d0fbd3c2f92cee74fd443eb5c252b8dd9b75b43.tar.gz
gnu: libgit2: Enable SHA-1 collision detection.
* gnu/packages/version-control.scm (libgit2)[arguments]: Enable '-DUSE_SHA1DC' in #:configure-flags.
-rw-r--r--gnu/packages/version-control.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index bc4242fc10..9667b2f3ec 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -347,7 +347,8 @@ everything from small to very large projects with speed and efficiency.")
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments
- `(#:phases
+ `(#:configure-flags '("-DUSE_SHA1DC=ON") ; SHA-1 collision detection
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-hardcoded-paths
(lambda _