summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-14 09:41:38 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-14 09:41:38 +0200
commit28206a8ebfad9f6cfa786d3cfd00ee1c1dfbbc65 (patch)
treeb6c18c57d728f7c21e2b70029aae9657530ca0ea
parent9f44dfc077e68308d80c4ddc684015edf4d9aa5f (diff)
downloadpatches-28206a8ebfad9f6cfa786d3cfd00ee1c1dfbbc65.tar
patches-28206a8ebfad9f6cfa786d3cfd00ee1c1dfbbc65.tar.gz
gnu: automake: Adjust test to ignore new gzip warnings.
* gnu/packages/patches/automake-test-gzip-warning.patch: New file. * gnu/packages/autotools.scm (automake)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/autotools.scm3
-rw-r--r--gnu/packages/patches/automake-test-gzip-warning.patch17
3 files changed, 20 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b734576b6e..cdb76cb5f0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -435,6 +435,7 @@ dist_patch_DATA = \
%D%/packages/patches/audacity-fix-ffmpeg-binding.patch \
%D%/packages/patches/automake-skip-amhello-tests.patch \
%D%/packages/patches/automake-regexp-syntax.patch \
+ %D%/packages/patches/automake-test-gzip-warning.patch \
%D%/packages/patches/avahi-localstatedir.patch \
%D%/packages/patches/avidemux-install-to-lib.patch \
%D%/packages/patches/avrdude-fix-libusb.patch \
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index de7f1f6d15..21ed0e6179 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -218,7 +218,8 @@ output is indexed in many ways to simplify browsing.")
"0dl6vfi2lzz8alnklwxzfz624b95hb1ipjvd3mk177flmddcf24r"))
(patches
(search-patches "automake-regexp-syntax.patch"
- "automake-skip-amhello-tests.patch"))))
+ "automake-skip-amhello-tests.patch"
+ "automake-test-gzip-warning.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,(autoconf-wrapper))
diff --git a/gnu/packages/patches/automake-test-gzip-warning.patch b/gnu/packages/patches/automake-test-gzip-warning.patch
new file mode 100644
index 0000000000..bcc9c207ae
--- /dev/null
+++ b/gnu/packages/patches/automake-test-gzip-warning.patch
@@ -0,0 +1,17 @@
+Adjust test to ignore gzip 1.8+ warnings.
+
+--- automake-1.15/t/distcheck-no-prefix-or-srcdir-override.sh 2016-06-14 00:36:26.554218552 +0200
++++ automake-1.15/t/distcheck-no-prefix-or-srcdir-override.sh 2016-06-14 00:37:52.903157770 +0200
+@@ -49,7 +49,11 @@ grep "cannot find sources.* in foobar" s
+
+ ./configure
+ run_make -E -O distcheck
+-test ! -s stderr
++
++# Gzip 1.8+ emits warnings like "gzip: warning: GZIP environment
++# variable is deprecated"; filter them out.
++test `grep -v '^gzip: warning' stderr | wc -l` -eq 0
++
+ # Sanity check: the flags have been actually seen.
+ $PERL -e 'undef $/; $_ = <>; s/ \\\n/ /g; print;' <stdout >t
+ grep '/configure .* --srcdir am-src' t || exit 99