summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2017-07-22 18:57:02 -0400
committerLudovic Courtès <ludo@gnu.org>2017-08-01 15:32:59 +0200
commit1f0d47059d31bbbaf588a4ca2de38d2ded8678cc (patch)
tree00c18679be4bfbe23a518abe59fe4fb5438a391b
parent04b6d6f7f7a73e39dcff1e2bca3113ea567e2944 (diff)
downloadpatches-1f0d47059d31bbbaf588a4ca2de38d2ded8678cc.tar
patches-1f0d47059d31bbbaf588a4ca2de38d2ded8678cc.tar.gz
gnu: emacs-yasnippet: Upgrade to 0.12.0.
* gnu/packages/emacs.scm (emacs-yasnippet): Upgrade to 0.12.0. [source]: Remove an uninstalled directory from yas-snippet-dirs. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 02e7a9e908..f6411c78c7 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4112,7 +4112,7 @@ mode-line.")
(define-public emacs-yasnippet
(package
(name "emacs-yasnippet")
- (version "0.11.0")
+ (version "0.12.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/joaotavora/yasnippet/"
@@ -4120,7 +4120,18 @@ mode-line.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "15di6mkkf09b7qddpsrm0qln02hji3sx8blya5jxssi9wxxx9iq5"))))
+ "1yqiprighgqz1hsslph50cy09xxqabc06jffrnjcsdf6nj70xlkc"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; YASnippet expects a "snippets" subdirectory in the same
+ ;; directory as yasnippet.el, but we don't install it
+ ;; because it's a git submodule pointing to an external
+ ;; repository. Adjust `yas-snippet-dirs' to prevent
+ ;; warnings about a missing directory.
+ (substitute* "yasnippet.el"
+ (("^ +'yas-installed-snippets-dir\\)\\)\n")
+ "))\n"))))))
(build-system emacs-build-system)
(home-page "https://github.com/joaotavora/yasnippet")
(synopsis "Yet another snippet extension for Emacs")