summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-02-09 22:51:10 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-02-11 20:23:19 +0200
commitd883e791b79e919796c03a88688c91b4b17550ea (patch)
tree98105373fa8c307adc3a31f7e1c1c11f0b768946
parent6e18b41eb71ea755bd10f1f7536426260d0fa3d9 (diff)
downloadpatches-d883e791b79e919796c03a88688c91b4b17550ea.tar
patches-d883e791b79e919796c03a88688c91b4b17550ea.tar.gz
gnu: ripgrep: Enable the 'pcre2' feature.
* gnu/packages/rust-apps.scm (ripgrep)[arguments]: Add '#:cargo-build-flags' to specify the feature. Replace 'install phase. [native-inputs]: Add pcre2, pkg-config. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/rust-apps.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index ddc9f6ed37..ac50f9591a 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -27,6 +27,7 @@
#:use-module (gnu packages crates-io)
#:use-module (gnu packages documentation)
#:use-module (gnu packages jemalloc)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control))
@@ -242,9 +243,22 @@ provides defaults for 80% of the use cases.")
(install-file manpage (string-append
(assoc-ref outputs "out")
"/share/man/man1"))))
- #t)))))
+ #t))
+ (replace 'install
+ ;; Adapted from (guix build cargo-build-system). The flags need to
+ ;; be passed to `cargo install' too, as otherwise it will build
+ ;; another binary, without the features.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p out)
+ (setenv "CARGO_TARGET_DIR" "./target")
+ (invoke "cargo" "install" "--path" "." "--root" out
+ "--features" "pcre2")))))
+ #:cargo-build-flags '("--release" "--features" "pcre2")))
(native-inputs
- `(("asciidoc" ,asciidoc)))
+ `(("asciidoc" ,asciidoc)
+ ("pcre2" ,pcre2)
+ ("pkg-config" ,pkg-config)))
(home-page "https://github.com/BurntSushi/ripgrep")
(synopsis "Line-oriented search tool")
(description