summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-15 03:32:29 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-11 21:35:21 +0200
commit953297c271c53ed43d17310d54efbebc1e456e38 (patch)
tree8485357eace0b3c62466fecda39c24ba5c93d16c
parent8940cfa211f36e6e2e645ff34ded2dbb7af718f5 (diff)
downloadpatches-953297c271c53ed43d17310d54efbebc1e456e38.tar
patches-953297c271c53ed43d17310d54efbebc1e456e38.tar.gz
gnu: Add rust-futures-io-0.3.
* gnu/packages/crates-io.scm (rust-futures-io-0.3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7bc69465d2..2a530f9461 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4171,6 +4171,28 @@ the computation on the threads themselves.")
library.")
(license (list license:expat license:asl2.0))))
+(define-public rust-futures-io-0.3
+ (package
+ (name "rust-futures-io")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "futures-io" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zxm41fmkrb0r39ajk3rr9invcd5bdwlafazn8m9aw4y49ymfxp6"))))
+ (build-system cargo-build-system)
+ (home-page "https://rust-lang-nursery.github.io/futures-rs")
+ (synopsis
+ "`AsyncRead` and `AsyncWrite` traits for the futures-rs library")
+ (description
+ "This package provides the @code{AsyncRead} and @code{AsyncWrite} traits
+for the futures-rs library.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-futures-io-preview-0.3
(package
(name "rust-futures-io-preview")