summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-02-09 22:51:09 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-02-11 20:23:19 +0200
commit6e18b41eb71ea755bd10f1f7536426260d0fa3d9 (patch)
treeb2fcef8642c5ab0b7a4981dcc9beab4e0dea256c
parent113afb4990bd6588f1587828dbd97c52496f568d (diff)
downloadpatches-6e18b41eb71ea755bd10f1f7536426260d0fa3d9.tar
patches-6e18b41eb71ea755bd10f1f7536426260d0fa3d9.tar.gz
gnu: ripgrep: Install the manpage.
* gnu/packages/rust-apps.scm (ripgrep)[native-inputs]: Add asciidoc. [arguments]: Add 'install-manpage phase. Import (ice-9 match). Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/rust-apps.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index d1d7d225a7..ddc9f6ed37 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -25,6 +25,7 @@
#:use-module (guix packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages crates-io)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages jemalloc)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages tls)
@@ -226,7 +227,24 @@ provides defaults for 80% of the use cases.")
("rust-termcolor" ,rust-termcolor-1.0))
#:cargo-development-inputs
(("rust-serde" ,rust-serde-1.0)
- ("rust-serde-derive" ,rust-serde-derive-1.0))))
+ ("rust-serde-derive" ,rust-serde-derive-1.0))
+ #:modules ((ice-9 match)
+ (guix build cargo-build-system)
+ (guix build utils))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'install-manpage
+ ;; NOTE: This is done before 'check so that there's only one output
+ ;; directory with the man page.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (match (find-files "target" "^rg\\.1$")
+ ((manpage)
+ (install-file manpage (string-append
+ (assoc-ref outputs "out")
+ "/share/man/man1"))))
+ #t)))))
+ (native-inputs
+ `(("asciidoc" ,asciidoc)))
(home-page "https://github.com/BurntSushi/ripgrep")
(synopsis "Line-oriented search tool")
(description