summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-02-06 08:36:12 +0000
committerChristopher Baines <mail@cbaines.net>2020-02-11 08:40:32 +0000
commit59796dfd63f25f91238e4c1cb68a0b41cad5b848 (patch)
tree51ee52e9d35ae5e869c23644f10647f924ff55f7
parent41884bfa5b13b6ab2ea1e2922b0ee44a8d0f8d90 (diff)
downloadpatches-59796dfd63f25f91238e4c1cb68a0b41cad5b848.tar
patches-59796dfd63f25f91238e4c1cb68a0b41cad5b848.tar.gz
gnu: subversion: Support running the tests in parallel.
This drops the time to build the package on my machine from ~14 minutes to ~5 minutes. * gnu/packages/version-control.scm (subversion)[arguments]: Add set-PARALLEL phase to set the PARALLEL environment variable.
-rw-r--r--gnu/packages/version-control.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 2ca64e4cdc..69358695ce 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1448,6 +1448,10 @@ following features:
(substitute* "subversion/tests/libsvn_repos/repos-test.c"
(("#!/bin/sh") (string-append "#!" (which "sh"))))
#t))
+ (add-before 'check 'set-PARALLEL
+ (lambda _
+ (setenv "PARALLEL" (number->string (parallel-job-count)))
+ #t))
(add-after 'install 'install-perl-bindings
(lambda* (#:key outputs #:allow-other-keys)
;; Follow the instructions from 'subversion/bindings/swig/INSTALL'.