summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2020-02-10 17:30:07 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-11 09:25:59 +0100
commit41884bfa5b13b6ab2ea1e2922b0ee44a8d0f8d90 (patch)
tree01017456e3cbef8e6b4b96f4b2fee1c1be856d0b
parent281537f47b22de288370a0f843301c399b6378f7 (diff)
downloadpatches-41884bfa5b13b6ab2ea1e2922b0ee44a8d0f8d90.tar
patches-41884bfa5b13b6ab2ea1e2922b0ee44a8d0f8d90.tar.gz
gnu: Add cl-float-features.
* gnu/packages/lisp-xyz.scm (sbcl-float-features, cl-float-features, ecl-float-features): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0bff3110cc..15e181d5f2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10273,3 +10273,37 @@ generation functions from the GSL library.")
(define-public ecl-cl-randist
(sbcl-package->ecl-package sbcl-cl-randist))
+
+(define-public sbcl-float-features
+ (package
+ (name "sbcl-float-features")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/float-features.git")
+ (commit "d3ef60181635b0849aa28cfc238053b7ca4644b0")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yj419k7n59x6rh3grwr6frgwwyria2il6f7wxpfazm8cskv4lzr"))))
+ (build-system asdf-build-system/sbcl)
+ (synopsis "Common Lisp IEEE float portability library")
+ (description
+ "Portability library for IEEE float features that are not
+covered by the Common Lisp standard.")
+ (home-page "https://github.com/Shinmera/float-features")
+ (license license:zlib)
+ (inputs
+ `(("documentation-utils" ,sbcl-documentation-utils)))
+ (arguments
+ `(#:asd-system-name "float-features"
+ #:asd-file "float-features.asd"
+ #:tests? #f))))
+
+(define-public cl-float-features
+ (sbcl-package->cl-source-package sbcl-float-features))
+
+(define-public ecl-float-features
+ (sbcl-package->ecl-package sbcl-float-features))