summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-09 14:55:25 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-09 14:55:25 +0100
commitf8c2d32461d469f7133c7d79fe1b4eed5146aaf7 (patch)
tree3fd96143a7c32a77aeb1d7dce51a2f9c098a550f
parent794ebb6b74e692e33d17552fe14b30bb9b7b771d (diff)
downloadpatches-f8c2d32461d469f7133c7d79fe1b4eed5146aaf7.tar
patches-f8c2d32461d469f7133c7d79fe1b4eed5146aaf7.tar.gz
gnu: djview: Fix executable's name in desktop file.
* gnu/packages/djvu.scm (djview)[inputs]: Re-order inputs alphabetically. [arguments]: Add a phase to fix executable's name in desktop file.
-rw-r--r--gnu/packages/djvu.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/djvu.scm b/gnu/packages/djvu.scm
index 534d2db58b..7dd08fcbe6 100644
--- a/gnu/packages/djvu.scm
+++ b/gnu/packages/djvu.scm
@@ -73,11 +73,20 @@ utilities.")
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
(inputs
- `(("glib" ,glib)
+ `(("djvulibre" ,djvulibre)
+ ("glib" ,glib)
("libxt" ,libxt)
("libtiff" ,libtiff)
- ("qtbase" ,qtbase)
- ("djvulibre" ,djvulibre)))
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-desktop-file
+ ;; Executable is "djview", not "djview4".
+ (lambda _
+ (substitute* "desktopfiles/djvulibre-djview4.desktop"
+ (("Exec=djview4 %f") "Exec=djview %f"))
+ #t)))))
(home-page "http://djvu.sourceforge.net/")
(synopsis "Viewer for the DjVu image format")
(description "DjView is a standalone viewer for DjVu files.