summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTonton <tonton@riseup.net>2018-05-11 22:34:05 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-13 23:16:17 +0200
commit7d4e377ff5dfb0b708255e30741f2d26407f1677 (patch)
tree681b2b839ce8e55d44d0adec15216b99af888742
parente5d92c1ce197ec6da891f69565fe550f502f8e7c (diff)
downloadpatches-7d4e377ff5dfb0b708255e30741f2d26407f1677.tar
patches-7d4e377ff5dfb0b708255e30741f2d26407f1677.tar.gz
gnu: Add ghc-containers.
* gnu/packages/haskell.scm (ghc-containers): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c65df28218..39c0c0a4cd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9490,4 +9490,35 @@ within appropriate monads, as well as some instances of these classes.")
(home-page "https://hackage.haskell.org/package/array")
(license license:bsd-3)))
+(define-public ghc-containers
+ (package
+ (name "ghc-containers")
+ (version "0.5.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://hackage.haskell.org/package/containers-0.5.11.0/containers-"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0j29w09kvcn1c0yi4clmrdbgs2gqmpxs2m7q80ib2ix1smm25kaq"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-array" ,ghc-array)
+ ("ghc-deepseq" ,ghc-deepseq-generics)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-chasingbottoms" ,ghc-chasingbottoms)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-ghc-prim" ,ghc-primitive)))
+ (synopsis "Haskell containers: Assorted concrete container types")
+ (description "This Haskell module provides efficient general-purpose
+implementations of various immutable container types including sets, maps,
+sequences, trees, and graphs.")
+ (home-page "https://hackage.haskell.org/package/containers")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here