summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-02-09 15:31:24 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-09 15:35:12 +0100
commit371ca8ca8665a470260416e7b9f954e0bf96e7fa (patch)
tree4f85a771bd47e530d0de4b2aa6cf7fb61b58283b
parent6ffe72bbd210bec066683a2c562fc1c3e1dc1cb2 (diff)
downloadpatches-371ca8ca8665a470260416e7b9f954e0bf96e7fa.tar
patches-371ca8ca8665a470260416e7b9f954e0bf96e7fa.tar.gz
gnu: Add eboard.
* gnu/packages/games.scm (eboard): New variable.
-rw-r--r--gnu/packages/games.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b502cd0ec4..78e0042aac 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9666,3 +9666,47 @@ challenges.")
license:bsd-3 ;src/md5sum
license:lgpl2.1+ ;src/iqsort.h
license:expat))))
+
+(define-public eboard
+ (package
+ (name "eboard")
+ (version "1.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fbergo/eboard.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z4pwpqyvxhlda99h6arh2rjk90fbms9q29fqizjblrdn01dlxn1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+-2)
+ ("libpng" ,libpng)
+ ("gstreamer" ,gstreamer)))
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (make-file-writable "eboard-config")
+ (setenv "CC" "gcc")
+ (invoke "./configure"
+ (string-append "--prefix=" (assoc-ref outputs "out")))
+ #t))
+ (add-before 'install 'make-required-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (mkdir-p (string-append (assoc-ref outputs "out")
+ "/share/eboard"))
+ #t)))))
+ (synopsis "Graphical user interface to play chess")
+ (description
+ "Eboard is a chess board interface for ICS (Internet Chess Servers)
+and chess engines.")
+ (home-page "https://www.bergo.eng.br/eboard/")
+ (license license:gpl2+)))