summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-02-09 11:33:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-02-09 11:33:00 +0200
commit243603c8889a9a1318cd7118177f7fae3aa4c348 (patch)
tree5e69c538989724512cb3f72e2bfe9bc0f16d1785
parentc6b806228af270a830bf41fc2cedf0a2b2191ea9 (diff)
downloadpatches-243603c8889a9a1318cd7118177f7fae3aa4c348.tar
patches-243603c8889a9a1318cd7118177f7fae3aa4c348.tar.gz
gnu: Add rust-structopt-derive-0.2.
* gnu/packages/crates-io.scm (rust-structopt-derive-0.2): New variable.
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b36d663305..b891369112 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -11754,6 +11754,32 @@ and Jaro-Winkler.")
(base32
"0sjsm7hrvjdifz661pjxq5w4hf190hx53fra8dfvamacvff139cf"))))))
+(define-public rust-structopt-derive-0.2
+ (package
+ (name "rust-structopt-derive")
+ (version "0.2.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "structopt-derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01sis9z5kqmyhvzbnmlzpdxcry99a0b9blypksgnhdsbm1hh40ak"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-heck" ,rust-heck-0.3)
+ ("rust-proc-macro2" ,rust-proc-macro2-0.4)
+ ("rust-quote" ,rust-quote-0.6)
+ ("rust-syn" ,rust-syn-0.15))))
+ (home-page "https://github.com/TeXitoi/structopt")
+ (synopsis
+ "Parse command line argument by defining a struct, derive crate")
+ (description
+ "Parse command line argument by defining a struct, derive crate.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-syn-1.0
(package
(name "rust-syn")