summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-01-31 20:59:29 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-02-06 10:48:14 +0200
commitd57000cf43f4650be7e8484f0a53c0f13326100a (patch)
tree0c7170afab13255653e2fafc625f125dd79eb448
parent53bf4857a422e9e09eb807a636aed2848e255f49 (diff)
downloadpatches-d57000cf43f4650be7e8484f0a53c0f13326100a.tar
patches-d57000cf43f4650be7e8484f0a53c0f13326100a.tar.gz
gnu: Add rust-natord-1.0.
* gnu/packages/crates-io.scm (rust-natord-1.0): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0c5cc3b69c..1e2bb8e88d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6641,6 +6641,26 @@ checking.")
(properties '((hidden? . #t)))
(license license:expat)))
+(define-public rust-natord-1.0
+ (package
+ (name "rust-natord")
+ (version "1.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "natord" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0z75spwag3ch20841pvfwhh3892i2z2sli4pzp1jgizbipdrd39h"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/lifthrasiir/rust-natord")
+ (synopsis "Natural ordering for Rust")
+ (description
+ "This package provides a crate to perform natural ordering for Rust.")
+ (license license:expat)))
+
(define-public rust-net2-0.2
(package
(name "rust-net2")