summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2020-02-06 12:53:57 -0800
committerVagrant Cascadian <vagrant@debian.org>2020-02-06 13:01:31 -0800
commitb1daba942eebf6cea1f9aab4a82027b20e29d11c (patch)
treec114582c54e193c917bf3075d047543ec526d48e
parent57f06234c7cb64a1d9c6d3fd1a9837b43b20a7eb (diff)
downloadpatches-b1daba942eebf6cea1f9aab4a82027b20e29d11c.tar
patches-b1daba942eebf6cea1f9aab4a82027b20e29d11c.tar.gz
gnu: Add python-rstr.
* gnu/packages/python-xyz (python-rstr): New variable.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dcc1595446..61accf8d0d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2922,6 +2922,27 @@ for SSH and SFTP. It has the following main usages:
@end itemize")
(license license:asl2.0)))
+(define-public python-rstr
+ (package
+ (name "python-rstr")
+ (version "2.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rstr" version))
+ (sha256
+ (base32
+ "197dw8mbq0pjjz1l6h1ksi62vgn7x55d373ch74y06744qiq5sjx"))))
+ (build-system python-build-system)
+ (home-page
+ "http://bitbucket.org/leapfrogdevelopment/rstr/overview")
+ (synopsis "Generate random strings in Python")
+ (description "This package provides a python module for generating
+random strings of various types. It could be useful for fuzz testing,
+generating dummy data, or other applications. It has no dependencies
+outside the standard library.")
+ (license license:bsd-3)))
+
(define-public python-scp
(package
(name "python-scp")