summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-02-05 20:59:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-02-06 10:48:16 +0200
commit6030b76570e950b1d2c3cd13431a1a320622bac8 (patch)
tree47f192061b5d937d632e23ee6dda897bcb0515cc
parent494fc97cd4a919ddce8c8d2c2ff1c0c1b1b7fd25 (diff)
downloadpatches-6030b76570e950b1d2c3cd13431a1a320622bac8.tar
patches-6030b76570e950b1d2c3cd13431a1a320622bac8.tar.gz
gnu: rust-openssl-sys-0.9: Don't skip build.
* gnu/packages/crates-io.scm (rust-openssl-sys-0.9)[source]: Add patch. [arguments]: Don't skip build. * gnu/packages/patches/rust-openssl-sys-no-vendor.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/crates-io.scm10
-rw-r--r--gnu/packages/patches/rust-openssl-sys-no-vendor.patch23
3 files changed, 29 insertions, 5 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0096010f14..f105f11913 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1378,6 +1378,7 @@ dist_patch_DATA = \
%D%/packages/patches/rust-bootstrap-stage0-test.patch \
%D%/packages/patches/rust-coresimd-doctest.patch \
%D%/packages/patches/rust-reproducible-builds.patch \
+ %D%/packages/patches/rust-openssl-sys-no-vendor.patch \
%D%/packages/patches/rxvt-unicode-escape-sequences.patch \
%D%/packages/patches/sbcl-graph-asdf-definitions.patch \
%D%/packages/patches/scalapack-blacs-mpi-deprecations.patch \
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b9836cade4..ebd6ea58b1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26,6 +26,7 @@
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages jemalloc)
#:use-module (gnu packages pcre)
@@ -7403,19 +7404,18 @@ system for OpenSSL.")
(origin
(method url-fetch)
(uri (crate-uri "openssl-sys" version))
- (file-name (string-append name "-" version ".crate"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0vvk8vzrc73y8n5rf4yj3x8ygyxjaz7wxrbxiwqi7qy0gyp1cpa6"))))
+ (base32 "0vvk8vzrc73y8n5rf4yj3x8ygyxjaz7wxrbxiwqi7qy0gyp1cpa6"))
+ (patches (search-patches "rust-openssl-sys-no-vendor.patch"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t ; it wants rust-openssl-src
- #:cargo-inputs
+ `(#:cargo-inputs
(("rust-libc" ,rust-libc-0.2)
;; Build dependencies:
("rust-autocfg" ,rust-autocfg-0.1)
("rust-cc" ,rust-cc-1.0)
("rust-pkg-config" ,rust-pkg-config-0.3)
- ;("rust-openssl-src" ,rust-openssl-src-111)
("rust-vcpkg" ,rust-vcpkg-0.2))
#:phases
(modify-phases %standard-phases
diff --git a/gnu/packages/patches/rust-openssl-sys-no-vendor.patch b/gnu/packages/patches/rust-openssl-sys-no-vendor.patch
new file mode 100644
index 0000000000..78a6b5e3f7
--- /dev/null
+++ b/gnu/packages/patches/rust-openssl-sys-no-vendor.patch
@@ -0,0 +1,23 @@
+https://sources.debian.org/data/main/r/rust-openssl-sys/0.9.53-1/debian/patches/disable-vendor.patch
+"MIT" licensed according to debian/copyright file
+slightly modified to only change the vendored openssl-src dependency
+
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -31,14 +31,11 @@
+ [build-dependencies.cc]
+ version = "1.0"
+
+-[build-dependencies.openssl-src]
+-version = "111.0.1"
+-optional = true
+-
+ [build-dependencies.pkg-config]
+ version = "0.3.9"
+
+ [features]
+ vendored = ["openssl-src"]
++openssl-src = []
+ [target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
+ version = "0.2"
+