summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-13 16:44:02 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-13 23:12:43 +0100
commit59e80445882f8b0379e54916f89510c0deda6698 (patch)
tree2769fffa217f630349c5a7207ee92204af046f9d
parent13f62aef2d87dc888f89fea3260eaa39938e6640 (diff)
downloadpatches-59e80445882f8b0379e54916f89510c0deda6698.tar
patches-59e80445882f8b0379e54916f89510c0deda6698.tar.gz
Remove traces of "GuixSD".
* gnu/bootloader/extlinux.scm (extlinux-configuration-file): Remove mentions of "GuixSD". * gnu/bootloader/grub.scm (install-grub-efi): Likewise. * gnu/build/vm.scm (make-iso9660-image): Change default #:volume-id to "Guix_image". (initialize-hard-disk): Search for the "Guix_image" label. * gnu/ci.scm (system-test-jobs, tarball-jobs): Remove "GuixSD". * gnu/installer/newt/welcome.scm (run-welcome-page): Likewise. * gnu/packages/audio.scm (supercollider)[description]: Likewise. * gnu/packages/curl.scm (curl): Likewise. * gnu/packages/emacs.scm (emacs): Likewise. * gnu/packages/gnome.scm (network-manager): Likewise. * gnu/packages/julia.scm (julia): Likewise. * gnu/packages/linux.scm (alsa-plugins): Likewise. (powertop, wireless-regdb): Likewise. * gnu/packages/package-management.scm (guix): Likewise. * gnu/packages/polkit.scm (polkit): Likewise. * gnu/packages/tex.scm (texlive-bin): Likewise. * gnu/services/base.scm (file-systems->fstab): Likewise. * gnu/services/cups.scm (%cups-activation): Likewise. * gnu/services/mail.scm (%dovecot-activation): Likewise. * gnu/services/messaging.scm (prosody-configuration)[log]: Likewise. * gnu/system/examples/vm-image.tmpl (vm-image-motd): Likewise. * gnu/system/install.scm (installation-os)[file-systems]: Change root file system label to "Guix_image". * gnu/system/mapped-devices.scm (check-device-initrd-modules): Remove "GuixSD". * gnu/system/vm.scm (system-docker-image): Likewise. (system-disk-image)[root-label]: Change to "Guix_image". * gnu/tests/install.scm (run-install): Remove "GuixSD". * guix/modules.scm (guix-module-name?): Likewise. * nix/libstore/optimise-store.cc: Likewise.
-rw-r--r--doc/guix.texi2
-rw-r--r--gnu/bootloader/extlinux.scm4
-rw-r--r--gnu/bootloader/grub.scm8
-rw-r--r--gnu/build/vm.scm6
-rw-r--r--gnu/ci.scm4
-rw-r--r--gnu/installer/newt/welcome.scm4
-rw-r--r--gnu/packages/audio.scm2
-rw-r--r--gnu/packages/curl.scm2
-rw-r--r--gnu/packages/emacs.scm2
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/julia.scm2
-rw-r--r--gnu/packages/kde-frameworks.scm2
-rw-r--r--gnu/packages/linux.scm6
-rw-r--r--gnu/packages/package-management.scm4
-rw-r--r--gnu/packages/polkit.scm2
-rw-r--r--gnu/packages/tex.scm2
-rw-r--r--gnu/services/base.scm2
-rw-r--r--gnu/services/cups.scm2
-rw-r--r--gnu/services/mail.scm2
-rw-r--r--gnu/services/messaging.scm2
-rw-r--r--gnu/system/examples/vm-image.tmpl2
-rw-r--r--gnu/system/install.scm2
-rw-r--r--gnu/system/mapped-devices.scm4
-rw-r--r--gnu/system/vm.scm6
-rw-r--r--gnu/tests/install.scm4
-rw-r--r--guix/modules.scm4
-rw-r--r--nix/libstore/optimise-store.cc2
27 files changed, 43 insertions, 43 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index cf0e6d0ca2..1b2ef37367 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -16484,7 +16484,7 @@ Defaults to @samp{"internal_plain"}.
@deftypevr {@code{prosody-configuration} parameter} maybe-string log
Set logging options. Advanced logging configuration is not yet supported
-by the Guix Prosody Service. See @url{https://prosody.im/doc/logging}.
+by the Prosody service. See @url{https://prosody.im/doc/logging}.
Defaults to @samp{"*syslog"}.
@end deftypevr
diff --git a/gnu/bootloader/extlinux.scm b/gnu/bootloader/extlinux.scm
index b48596c496..2bb711eed1 100644
--- a/gnu/bootloader/extlinux.scm
+++ b/gnu/bootloader/extlinux.scm
@@ -57,10 +57,10 @@ corresponding to old generations of the system."
#~(call-with-output-file #$output
(lambda (port)
(let ((timeout #$(bootloader-configuration-timeout config)))
- (format port "# This file was generated from your GuixSD configuration. Any changes
+ (format port "# This file was generated from your Guix configuration. Any changes
# will be lost upon reconfiguration.
UI menu.c32
-MENU TITLE GuixSD Boot Options
+MENU TITLE GNU Guix Boot Options
PROMPT ~a
TIMEOUT ~a~%"
(if (> timeout 0) 1 0)
diff --git a/gnu/bootloader/grub.scm b/gnu/bootloader/grub.scm
index 161e8b3d02..51d5787364 100644
--- a/gnu/bootloader/grub.scm
+++ b/gnu/bootloader/grub.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -334,7 +334,7 @@ entries corresponding to old generations of the system."
#~(call-with-output-file #$output
(lambda (port)
(format port
- "# This file was generated from your GuixSD configuration. Any changes
+ "# This file was generated from your Guix configuration. Any changes
# will be lost upon reconfiguration.
")
#$sugar
@@ -380,7 +380,7 @@ submenu \"GNU system, old configurations...\" {~%")
;; system whose root is mounted at MOUNT-POINT.
(let ((grub-install (string-append bootloader "/sbin/grub-install"))
(install-dir (string-append mount-point "/boot"))
- ;; When installing GuixSD, it's common to mount EFI-DIR below
+ ;; When installing Guix, it's common to mount EFI-DIR below
;; MOUNT-POINT rather than /boot/efi on the live image.
(target-esp (if (file-exists? (string-append mount-point efi-dir))
(string-append mount-point efi-dir)
@@ -389,7 +389,7 @@ submenu \"GNU system, old configurations...\" {~%")
;; root partition.
(setenv "GRUB_ENABLE_CRYPTODISK" "y")
(unless (zero? (system* grub-install "--boot-directory" install-dir
- "--bootloader-id=GuixSD"
+ "--bootloader-id=Guix"
"--efi-directory" target-esp))
(error "failed to install GRUB (EFI)")))))
diff --git a/gnu/build/vm.scm b/gnu/build/vm.scm
index 0aef73d26d..6d6a0c4cb4 100644
--- a/gnu/build/vm.scm
+++ b/gnu/build/vm.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -422,7 +422,7 @@ SYSTEM-DIRECTORY is the name of the directory of the 'system' derivation."
(string-append "boot/grub/grub.cfg=" config-file))))
(define* (make-iso9660-image grub config-file os-drv target
- #:key (volume-id "GuixSD_image") (volume-uuid #f)
+ #:key (volume-id "Guix_image") (volume-uuid #f)
register-closures? (closures '()))
"Given a GRUB package, creates an iso image as TARGET, using CONFIG-FILE as
GRUB configuration and OS-DRV as the stuff in it."
@@ -550,7 +550,7 @@ passing it a directory name where it is mounted."
(lambda (port)
(format port
"insmod part_msdos~@
- search --set=root --label GuixSD_image~@
+ search --set=root --label Guix_image~@
configfile /boot/grub/grub.cfg~%")))
(display "creating EFI firmware image...")
diff --git a/gnu/ci.scm b/gnu/ci.scm
index 2c04b7189d..e108b4b15b 100644
--- a/gnu/ci.scm
+++ b/gnu/ci.scm
@@ -235,7 +235,7 @@ system.")
(system-test-value test))))
`((derivation . ,(derivation-file-name drv))
- (description . ,(format #f "GuixSD '~a' system test"
+ (description . ,(format #f "Guix '~a' system test"
(system-test-name test)))
(long-description . ,(system-test-description test))
(license . ,(license-name gpl3+))
@@ -270,7 +270,7 @@ system.")
`((derivation . ,(derivation-file-name drv))
(description . "Stand-alone binary Guix tarball")
(long-description . "This is a tarball containing binaries of Guix and
-all its dependencies, and ready to be installed on non-GuixSD distributions.")
+all its dependencies, and ready to be installed on \"foreign\" distributions.")
(license . ,(license-name gpl3+))
(home-page . ,%guix-home-page-url)
(maintainers . ("bug-guix@gnu.org"))))
diff --git a/gnu/installer/newt/welcome.scm b/gnu/installer/newt/welcome.scm
index eec98e291a..b0b5429c0f 100644
--- a/gnu/installer/newt/welcome.scm
+++ b/gnu/installer/newt/welcome.scm
@@ -92,8 +92,8 @@ we want this page to occupy all the screen space available."
the page. Ask the user to choose between manual installation, graphical
installation and reboot."
(run-menu-page
- (G_ "GNU GuixSD install")
- (G_ "Welcome to GNU GuixSD installer!
+ (G_ "GNU Guix install")
+ (G_ "Welcome to GNU Guix system installer!
Please note that the present graphical installer is still under heavy \
development, so you might want to prefer using the shell based process. \
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 91bb467de6..8bcd3c4b85 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2270,7 +2270,7 @@ for experimenting with sound synthesis and algorithmic composition.
SuperCollider requires jackd to be installed in your user profile and your
user must be allowed to access the realtime features of the kernel. Search
for \"realtime\" in the index of the Guix manual to learn how to achieve this
-using GuixSD.")
+using Guix System.")
(license license:gpl2+)))
(define-public raul
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 822fe17036..456a18012d 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -108,7 +108,7 @@
(("/bin/sh") (which "sh")))
;; XXX FIXME: Test #1510 seems to work on some machines and not
- ;; others, possibly based on the kernel version. It works on GuixSD
+ ;; others, possibly based on the kernel version. It works on Guix System
;; on x86_64 with linux-libre-4.1, but fails on Hydra for both i686
;; and x86_64 with the following error:
;;
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1e76f0821c..74005972db 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -92,7 +92,7 @@
'("eshell/esh-groups.el")))
;; Make sure Tramp looks for binaries in the right places on
- ;; remote GuixSD machines, where 'getconf PATH' returns
+ ;; remote Guix System machines, where 'getconf PATH' returns
;; something bogus.
(substitute* "net/tramp-sh.el"
;; Patch the line after "(defcustom tramp-remote-path".
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0344e42444..3d67b7b9c1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5161,7 +5161,7 @@ users.")
(doc (assoc-ref %outputs "doc"))
(dhclient (string-append (assoc-ref %build-inputs "isc-dhcp")
"/sbin/dhclient")))
- (list "--with-systemd-logind=yes" ;In GuixSD, this is provided by elogind.
+ (list "--with-systemd-logind=yes" ;In Guix System, this is provided by elogind.
"--with-consolekit=no"
"--with-crypto=gnutls"
"--disable-config-plugin-ibft"
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index a2e1264503..fa9709c40c 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -148,7 +148,7 @@
(use-modules (ice-9 match))
(substitute* "src/runtime_ccall.cpp"
;; Patch out invocations of '/sbin/ldconfig' to avoid getting
- ;; error messages about missing '/sbin/ldconfig' on GuixSD.
+ ;; error messages about missing '/sbin/ldconfig' on Guix System.
(("popen\\(.*ldconfig.*\\);")
"NULL;\n")
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 2ae5feaf52..10a1dfe0d1 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3487,7 +3487,7 @@ workspace.")
("qtsvg" ,qtsvg)
("qttools" ,qttools)
("qtx11extras" ,qtx11extras)))
- ;; FIXME: Use GuixSD ca-bundle.crt in etc/xdg/ksslcalist and
+ ;; FIXME: Use Guix ca-bundle.crt in etc/xdg/ksslcalist and
;; share/kf5/kssl/ca-bundle.crt
;; TODO: NixOS has nix-kde-include-dir.patch to change std-dir "include"
;; into "@dev@/include/". Think about whether this is needed for us, too.
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e4a58834a9..1cdffb8c79 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1112,7 +1112,7 @@ MIDI functionality to the Linux-based operating system.")
(outputs '("out" "pulseaudio" "jack"))
(arguments
`(#:configure-flags '(;; Do not install a "local" configuration targeted
- ;; for /etc/alsa. On GuixSD plugins are loaded from
+ ;; for /etc/alsa. On Guix System plugins are loaded from
;; the ALSA service, and other distributions likely
;; won't use these files.
"--with-alsalconfdir=/tmp/noop")
@@ -1579,7 +1579,7 @@ devices. It replaces @code{iwconfig}, which is deprecated.")
'(#:phases
(modify-phases %standard-phases
;; TODO: Patch some hardcoded "wlan0" in calibrate/calibrate.cpp to
- ;; allow calibrating the network interface in GuixSD.
+ ;; allow calibrating the network interface in Guix System.
(add-after 'unpack 'patch-absolute-file-names
(lambda* (#:key inputs #:allow-other-keys)
(let ((kmod (assoc-ref inputs "kmod")))
@@ -2379,7 +2379,7 @@ compliance.")
#:tests? #f ;no tests
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list (string-append "PREFIX=" out)
- (string-append "LSB_ID=GuixSD")
+ (string-append "LSB_ID=Guix")
(string-append "DISTRO_PUBKEY=/dev/null")
(string-append "DISTRO_PRIVKEY=/dev/null")
(string-append "REGDB_PUBKEY=/dev/null")
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 1244cf2fc3..86e8fce1dc 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -142,8 +142,8 @@
;; Set 'DOT_USER_PROGRAM' to the empty string so
;; we don't keep a reference to Graphviz, whose
- ;; closure is pretty big (too big for the GuixSD
- ;; installation image.)
+ ;; closure is pretty big (too big for the Guix
+ ;; system installation image.)
"ac_cv_path_DOT_USER_PROGRAM=dot"
;; To avoid problems with the length of shebangs,
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index 0433b423eb..ba74a5c905 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -73,7 +73,7 @@
(substitute* "src/polkitbackend/polkitbackendjsauthority.cpp"
(("systemd") "elogind"))
- ;; GuixSD's polkit service stores actions under
+ ;; Guix System's polkit service stores actions under
;; /etc/polkit-1/actions.
(substitute* "src/polkitbackend/polkitbackendinteractiveauthority.c"
(("PACKAGE_DATA_DIR \"/polkit-1/actions\"")
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 584b2bcfa5..5b29937672 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -185,7 +185,7 @@
;; ps2eps.pl uses the "gswin32c" ghostscript executable on Windows,
;; and the "gs" ghostscript executable on Unix. It detects Unix by
;; checking for the existence of the /usr/bin directory. Since
- ;; GuixSD does not have /usr/bin, it is also detected as Windows.
+ ;; Guix System does not have /usr/bin, it is also detected as Windows.
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "utils/ps2eps/ps2eps-src/bin/ps2eps.pl"
(("gswin32c") "gs"))
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 67df4d1379..04b123b833 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -331,7 +331,7 @@ seconds after @code{SIGTERM} has been sent are terminated with
`(("fstab" ,(plain-file "fstab"
(string-append
"\
-# This file was generated from your GuixSD configuration. Any changes
+# This file was generated from your Guix configuration. Any changes
# will be lost upon reboot or reconfiguration.\n\n"
(string-join (map file-system->fstab-entry
file-systems)
diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
index 715d333a71..9125139ef3 100644
--- a/gnu/services/cups.scm
+++ b/gnu/services/cups.scm
@@ -862,7 +862,7 @@ IPP specifications.")
(define* (create-self-signed-certificate-if-absent
#:key private-key public-key (owner (getpwnam "root"))
(common-name (gethostname))
- (organization-name "GuixSD")
+ (organization-name "Guix")
(organization-unit-name "Default Self-Signed Certificate")
(subject-parameters `(("CN" . ,common-name)
("O" . ,organization-name)
diff --git a/gnu/services/mail.scm b/gnu/services/mail.scm
index fcaedd038b..a7e8c41d3a 100644
--- a/gnu/services/mail.scm
+++ b/gnu/services/mail.scm
@@ -1485,7 +1485,7 @@ greyed out, instead of only later giving \"not selectable\" popup error.
(define* (create-self-signed-certificate-if-absent
#:key private-key public-key (owner (getpwnam "root"))
(common-name (gethostname))
- (organization-name "GuixSD")
+ (organization-name "Guix")
(organization-unit-name "Default Self-Signed Certificate")
(subject-parameters `(("CN" . ,common-name)
("O" . ,organization-name)
diff --git a/gnu/services/messaging.scm b/gnu/services/messaging.scm
index e70f1b70ef..11b41f2bf6 100644
--- a/gnu/services/messaging.scm
+++ b/gnu/services/messaging.scm
@@ -461,7 +461,7 @@ about using the hashed backend. See also
(log
(maybe-string "*syslog")
"Set logging options. Advanced logging configuration is not yet supported
-by the GuixSD Prosody Service. See @url{https://prosody.im/doc/logging}."
+by the Prosody service. See @url{https://prosody.im/doc/logging}."
common)
(pidfile
diff --git a/gnu/system/examples/vm-image.tmpl b/gnu/system/examples/vm-image.tmpl
index 4d292c1bc6..6dc67b0901 100644
--- a/gnu/system/examples/vm-image.tmpl
+++ b/gnu/system/examples/vm-image.tmpl
@@ -8,7 +8,7 @@
(define vm-image-motd (plain-file "motd" "
This is the GNU system. Welcome!
-This instance of GuixSD is a bare-bones template for virtualized environments.
+This instance of Guix System is a bare-bones template for virtualized environments.
You will probably want to do these things first if you booted in a virtual
private server (VPS):
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index 0ba2066d11..bad318d06b 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -353,7 +353,7 @@ You have been warned. Thanks for being so brave.\x1b[0m
;; the appropriate one.
(cons* (file-system
(mount-point "/")
- (device (file-system-label "GuixSD_image"))
+ (device (file-system-label "Guix_image"))
(type "ext4"))
;; Make /tmp a tmpfs instead of keeping the overlayfs. This
diff --git a/gnu/system/mapped-devices.scm b/gnu/system/mapped-devices.scm
index a874666463..e29ad3ad38 100644
--- a/gnu/system/mapped-devices.scm
+++ b/gnu/system/mapped-devices.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017, 2018 Mark H Weaver <mhw@netris.org>
;;;
@@ -120,7 +120,7 @@
DEVICE must be a \"/dev\" file name."
(define aliases
;; Attempt to load 'modules.alias' from the current kernel, assuming we're
- ;; on GuixSD, and assuming that corresponds to the kernel we'll be
+ ;; on Guix System, and assuming that corresponds to the kernel we'll be
;; installing. Skip the whole thing if that file cannot be read.
(catch 'system-error
(lambda ()
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index e09c687a04..e561285964 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -463,8 +463,8 @@ the image."
"Build a docker image. OS is the desired <operating-system>. NAME is the
base name to use for the output file. When REGISTER-CLOSURES? is not #f,
register the closure of OS with Guix in the resulting Docker image. This only
-makes sense when you want to build a GuixSD Docker image that has Guix
-installed inside of it. If you don't need Guix (e.g., your GuixSD Docker
+makes sense when you want to build a Guix System Docker image that has Guix
+installed inside of it. If you don't need Guix (e.g., your Docker
image just contains a web server that is started by the Shepherd), then you
should set REGISTER-CLOSURES? to #f."
(define schema
@@ -610,7 +610,7 @@ to USB sticks meant to be read-only."
(define root-label
;; Volume name of the root file system.
- (normalize-label "GuixSD_image"))
+ (normalize-label "Guix_image"))
(define root-uuid
;; UUID of the root file system, computed in a deterministic fashion.
diff --git a/gnu/tests/install.scm b/gnu/tests/install.scm
index ec29064118..277908cc49 100644
--- a/gnu/tests/install.scm
+++ b/gnu/tests/install.scm
@@ -47,7 +47,7 @@
;;; Commentary:
;;;
-;;; Test the installation of GuixSD using the documented approach at the
+;;; Test the installation of Guix using the documented approach at the
;;; command line.
;;;
;;; Code:
@@ -204,7 +204,7 @@ reboot\n")
(guix combinators))))
(installation-disk-image-file-system-type "ext4")
(target-size (* 2200 MiB)))
- "Run SCRIPT (a shell script following the GuixSD installation procedure) in
+ "Run SCRIPT (a shell script following the system installation procedure) in
OS to install TARGET-OS. Return a VM image of TARGET-SIZE bytes containing
the installed system. The packages specified in PACKAGES will be appended to
packages defined in installation-os."
diff --git a/guix/modules.scm b/guix/modules.scm
index 65928f67f2..1a6fafe35b 100644
--- a/guix/modules.scm
+++ b/guix/modules.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -112,7 +112,7 @@ depends on."
".scm"))
(define (guix-module-name? name)
- "Return true if NAME (a list of symbols) denotes a Guix or GuixSD module."
+ "Return true if NAME (a list of symbols) denotes a Guix module."
(match name
(('guix _ ...) #t)
(('gnu _ ...) #t)
diff --git a/nix/libstore/optimise-store.cc b/nix/libstore/optimise-store.cc
index 71dc1be07f..d8f8d2394b 100644
--- a/nix/libstore/optimise-store.cc
+++ b/nix/libstore/optimise-store.cc
@@ -114,7 +114,7 @@ void LocalStore::optimisePath_(OptimiseStats & stats, const Path & path, InodeHa
/* Sometimes SNAFUs can cause files in the store to be
modified, in particular when running programs as root under
- GuixSD (example: $fontconfig/var/cache being modified). Skip
+ Guix System (example: $fontconfig/var/cache being modified). Skip
those files. FIXME: check the modification time. */
if (S_ISREG(st.st_mode) && (st.st_mode & S_IWUSR)) {
printMsg(lvlError, format("skipping suspicious writable file `%1%'") % path);