summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2020-02-06 12:54:48 -0800
committerVagrant Cascadian <vagrant@debian.org>2020-02-06 13:25:27 -0800
commit06d41d8d498dec2cedcb778cde50d13a5d95dc0e (patch)
treee6fc189ba84b2b3da0467ec3ceccbbcf26792bd3
parent0773d779bba28fd4498a67c77ce038804dede8e3 (diff)
downloadpatches-06d41d8d498dec2cedcb778cde50d13a5d95dc0e.tar
patches-06d41d8d498dec2cedcb778cde50d13a5d95dc0e.tar.gz
gnu: Add python-jsondiff.
Thanks to bavier for help with the description! * gnu/packages/python-xyz (python-jsondiff): New varaible.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 61accf8d0d..c32b3a1a95 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1990,6 +1990,28 @@ between Julian dates and Gregorian dates.")
(define-public python2-jdcal
(package-with-python2 python-jdcal))
+(define-public python-jsondiff
+ (package
+ (name "python-jsondiff")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jsondiff" version))
+ (sha256
+ (base32
+ "00v3689175aqzdscrxpffm712ylp8jvcpqdg51ca22ni6721p51l"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-nose-random" ,python-nose-random)))
+ (home-page
+ "https://github.com/fzumstein/jsondiff")
+ (synopsis "Compare JSON and JSON-like structures in Python")
+ (description "@code{jsondiff} is a Python library which lets you
+compare, diff, and patch JSON and JSON-like structures in Python.")
+ (license license:expat)))
+
(define-public python-jsonschema
(package
(name "python-jsonschema")