summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFakhri Sajadi <f.sajadi@pantherx.org>2020-02-05 13:37:23 +0330
committerMarius Bakke <mbakke@fastmail.com>2020-02-05 22:03:34 +0100
commit6cd07787ab371240caaf990a2e16cb48290e25d0 (patch)
tree78a29573c0333d344bd785ce63341a1afba8f314
parent567a14536881d891b73dd8bd9ab99d503f6d8578 (diff)
downloadpatches-6cd07787ab371240caaf990a2e16cb48290e25d0.tar
patches-6cd07787ab371240caaf990a2e16cb48290e25d0.tar.gz
gnu: lxqt-config: Fixing keyboard layout.
* gnu/packages/lxqt.scm (lxqt-config)[inputs]: Add xkeyboard-config. [arguments]: Add phase to substitute xkb rule file. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/lxqt.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 12c92e52d1..a440491633 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018, 2019 Meiyo Peng <meiyo@riseup.net>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Reza Alizadeh Majd <r.majd@pantherx.org>
+;;; Copyright © 2020 Fakhri Sajadi <f.sajadi@pantherx.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -379,6 +380,7 @@ the operating system LXQt is running on.")
("qtx11extras" ,qtx11extras)
("solid" ,solid)
("xf86-input-libinput" ,xf86-input-libinput)
+ ("xkeyboard-config" ,xkeyboard-config)
("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -394,6 +396,14 @@ the operating system LXQt is running on.")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
#t))
+ (add-after 'unpack 'set-xkeyboard-config-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Set the file name to xkeyboard-config.
+ (let ((xkb (assoc-ref inputs "xkeyboard-config")))
+ (substitute* "lxqt-config-input/keyboardlayoutconfig.h"
+ (("/usr/share/X11/xkb/rules/base.lst")
+ (string-append xkb "/share/X11/xkb/rules/base.lst")))
+ #t)))
(add-after 'unpack 'patch-translations-dir
(lambda* (#:key outputs #:allow-other-keys)
(substitute* '("lxqt-config-file-associations/CMakeLists.txt"