summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-01-30 13:37:11 +0000
committerMarius Bakke <mbakke@fastmail.com>2020-02-05 22:03:34 +0100
commit6a428d455e24769bc274dd80ecc959e954f7ff41 (patch)
tree57cc8ef969a3d4a7338d0f7c19f86247cf8f80ef
parente5fcff3190efec8a29f0c17b9c69793062f3c927 (diff)
downloadpatches-6a428d455e24769bc274dd80ecc959e954f7ff41.tar
patches-6a428d455e24769bc274dd80ecc959e954f7ff41.tar.gz
gnu: zrythm: Update to 0.7.474.
* gnu/packages/music.scm (zrythm): Update to 0.7.474. [arguments](phases): Patch xdg-open. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/music.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 41e8ba6f75..3ef04d7202 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5142,7 +5142,7 @@ and as an LV2 plugin.")
(define-public zrythm
(package
(name "zrythm")
- (version "0.7.345")
+ (version "0.7.474")
(source
(origin
(method url-fetch)
@@ -5150,13 +5150,21 @@ and as an LV2 plugin.")
version ".tar.xz"))
(sha256
(base32
- "1csiwq38a1ckx23lairfpl7qjkz71wsa7a9vsxl3k58f9ybibiil"))))
+ "0qq9v8y27zhamcb7nq7pl76874ws8x8cxhp5r685b8binvl9p0az"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
#:configure-flags
`("-Denable_tests=true" "-Dmanpage=true"
- "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")))
+ "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-xdg-open
+ (lambda _
+ (substitute* "src/utils/io.c"
+ (("OPEN_DIR_CMD")
+ (string-append "\"" (which "xdg-open") "\"")))
+ #t)))))
(inputs
`(("alsa-lib" ,alsa-lib)
("jack" ,jack-1)