summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-01-22 20:38:30 +0100
committerLudovic Courtès <ludo@gnu.org>2020-02-05 00:21:27 +0100
commite3d80f3c1cd66c1290d28f44722a4cd3892cb20b (patch)
tree9b426b5e7525ef44503e2e0e09286dc8d2f66856
parent6e43e1eee8b6ecf567686885e4707f889643b55b (diff)
downloadpatches-e3d80f3c1cd66c1290d28f44722a4cd3892cb20b.tar
patches-e3d80f3c1cd66c1290d28f44722a4cd3892cb20b.tar.gz
gnu: Add gnome-shell-extension-appindicator.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-appindicator): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0fc721b7d3..7f375fefc5 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -114,6 +114,40 @@ which haven't been updated for some years. The new app icons are ported from
the Obsidian icon theme.")
(license license:gpl3)))
+(define-public gnome-shell-extension-appindicator
+ (package
+ (name "gnome-shell-extension-appindicator")
+ (version "30")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/ubuntu/gnome-shell-extension-appindicator.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1fjhx23jqwv3d0smwhnjvc35gqhwk9p5f96ic22pfax653cn5vh8"))
+ (file-name (git-file-name name version))))
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((source (assoc-ref %build-inputs "source"))
+ (install-dir (string-append (assoc-ref %outputs "out")
+ "/share/gnome-shell/extensions"
+ "/appindicatorsupport@rgcjonas.gmail.com")))
+ (mkdir-p install-dir)
+ (copy-recursively source install-dir)
+ #t))))
+ (synopsis "Adds KStatusNotifierItem support to GNOME Shell")
+ (description "This extension integrates Ubuntu AppIndicators
+and KStatusNotifierItems (KDE's successor of the systray) into
+GNOME Shell.")
+ (home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
+ (license license:gpl2+)))
+
(define-public gnome-shell-extension-dash-to-dock
(package
(name "gnome-shell-extension-dash-to-dock")