summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmin Bandali <mab@gnu.org>2020-02-04 02:41:03 -0500
committerLeo Famulari <leo@famulari.name>2020-02-04 19:29:33 -0500
commitb2a6a784003e0bb7f958666186522fbdf2356071 (patch)
treefc903c2ed21c6529b55b252a369a5555d1409c75
parent861bd91b9a7860cebc7ff0813f8671cc2fc9f86d (diff)
downloadpatches-b2a6a784003e0bb7f958666186522fbdf2356071.tar
patches-b2a6a784003e0bb7f958666186522fbdf2356071.tar.gz
gnu: Add pamixer.base-for-series-2808
* gnu/packages/pulseaudio.scm (pamixer): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/pulseaudio.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 5651127b38..2bbe6c5bdd 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2020 Amin Bandali <mab@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,6 +38,7 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages dbm)
#:use-module (gnu packages glib)
@@ -365,3 +367,38 @@ install one or more of the following packages alongside pulseaudio-dlna:
@item vorbis-tools - Vorbis transcoding support
@end itemize")
(license l:gpl3+))))
+
+(define-public pamixer
+ (package
+ (name "pamixer")
+ (version "1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cdemoulins/pamixer.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1i14550n8paijwwnhksv5izgfqm3s5q2773bdfp6vyqybkll55f7"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There is no test suite.
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; There's no configure phase.
+ (add-before 'install 'mkdir-bin
+ (lambda _
+ (mkdir-p (string-append (assoc-ref %outputs "out") "/bin"))
+ #t)))))
+ (inputs
+ `(("boost" ,boost)
+ ("pulseaudio" ,pulseaudio)))
+ (home-page "https://github.com/cdemoulins/pamixer")
+ (synopsis "PulseAudio command line mixer")
+ (description
+ "pamixer is like amixer but for PulseAudio, allowing easy control of the
+volume levels of the sinks (get, set, decrease, increase, toggle mute, etc).")
+ (license l:gpl3+)))