summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-02-04 11:35:53 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-04 16:33:55 +0100
commit92da05885c780fb92694f0d84ceda093b1b67db8 (patch)
tree89a8123ada9ee4aa45f93db7718b732c4b5d60a2
parent54dc3ba2fb0061f41bc14d4edeee1a2dbe793701 (diff)
downloadpatches-92da05885c780fb92694f0d84ceda093b1b67db8.tar
patches-92da05885c780fb92694f0d84ceda093b1b67db8.tar.gz
gnu: sbcl-split-sequence: Update to 2.0.0.
* gnu/packages/lisp-xyz.scm (sbcl-split-sequence): Update to 2.0.0. [native-inputs]: Add fiveam. [arguments]: Don't ignore tests.
-rw-r--r--gnu/packages/lisp-xyz.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index e7372988db..ab1ec04bcd 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -1416,7 +1416,7 @@ In addition to regular Packrat / Parsing Grammar / TDPL features ESRAP supports:
(define-public sbcl-split-sequence
(package
(name "sbcl-split-sequence")
- (version "1.4.1")
+ (version "2.0.0")
(source
(origin
(method git-fetch)
@@ -1425,13 +1425,11 @@ In addition to regular Packrat / Parsing Grammar / TDPL features ESRAP supports:
(commit (string-append "v" version))))
(sha256
(base32
- "0c3zp6b7fmmp93sfhq112ind4zkld49ycw68z409xpnz3gc0wpf0"))
+ "0jcpnx21hkfwqj5fvp7kc6pn1qcz9hk7g2s5x8h0349x1j2irln0"))
(file-name (git-file-name "split-sequence" version))))
(build-system asdf-build-system/sbcl)
- (arguments
- ;; TODO: Tests seem to be broken.
- ;; https://github.com/sharplispers/split-sequence/issues/8
- `(#:tests? #f))
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
(synopsis "Member of the Common Lisp Utilities family of programs")
(description
"Splits sequence into a list of subsequences delimited by objects