summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-02-03 14:39:07 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-03 17:12:07 +0100
commit7b875e4efdbc50f321d7ee0b1ed1b74af289e660 (patch)
tree3ab437161683610a2e5097d4c4eea15e0a00d646
parentd165821ecc8419eec88cab7070746e36bbd0331f (diff)
downloadpatches-7b875e4efdbc50f321d7ee0b1ed1b74af289e660.tar
patches-7b875e4efdbc50f321d7ee0b1ed1b74af289e660.tar.gz
gnu: Add cl-zpng.
* gnu/packages/lisp-xyz.scm (sbcl-zpng, cl-zpng, ecl-zpng): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5f36b5d454..016d363b80 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10102,3 +10102,30 @@ respectively.")
(define-public ecl-png-read
(sbcl-package->ecl-package sbcl-png-read))
+
+(define-public sbcl-zpng
+ (package
+ (name "sbcl-zpng")
+ (version "1.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xach/zpng.git")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b3ag3jhl3z7kdls3ahdsdxsfhhw5qrizk769984f4wkxhb69rcm"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("salza2" ,sbcl-salza2)))
+ (synopsis "PNG encoder for Common Lisp")
+ (description "This is a Common Lisp library for creating PNG images.")
+ (home-page "https://www.xach.com/lisp/zpng/")
+ (license license:bsd-2)))
+
+(define-public cl-zpng
+ (sbcl-package->cl-source-package sbcl-zpng))
+
+(define-public ecl-zpng
+ (sbcl-package->ecl-package sbcl-zpng))