summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-02-03 14:26:31 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-03 17:12:07 +0100
commitd165821ecc8419eec88cab7070746e36bbd0331f (patch)
tree7e4dbd4e558063a7f0ac25c9de51b7951b9bc7a3
parent46cc2a38bce26e6a095c5a4efd1db1d4c8f109b6 (diff)
downloadpatches-d165821ecc8419eec88cab7070746e36bbd0331f.tar
patches-d165821ecc8419eec88cab7070746e36bbd0331f.tar.gz
gnu: Add cl-png-read.
* gnu/packages/lisp-xyz.scm (sbcl-png-read, cl-png-read, ecl-png-read): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2d04a434e0..5f36b5d454 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10071,3 +10071,34 @@ respectively.")
(define-public ecl-salza2
(sbcl-package->ecl-package sbcl-salza2))
+
+(define-public sbcl-png-read
+ (let ((commit "ec29f38a689972b9f1373f13bbbcd6b05deada88")
+ (revision "1"))
+ (package
+ (name "sbcl-png-read")
+ (version (git-version "0.3.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ramarren/png-read.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vyczbcwskrygrf1hgrsnk0jil8skmvf1kiaalw5jps4fjrfdkw0"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("babel" ,sbcl-babel)
+ ("chipz" ,sbcl-chipz)
+ ("iterate" ,sbcl-iterate)))
+ (synopsis "PNG decoder for Common Lisp")
+ (description "This is a Common Lisp library for reading PNG images.")
+ (home-page "https://github.com/Ramarren/png-read")
+ (license license:bsd-3))))
+
+(define-public cl-png-read
+ (sbcl-package->cl-source-package sbcl-png-read))
+
+(define-public ecl-png-read
+ (sbcl-package->ecl-package sbcl-png-read))