summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-02-01 14:00:37 +0100
committerLeo Famulari <leo@famulari.name>2020-02-02 16:11:34 -0500
commitcda982458501972c6e6a4927f96b21d286c93004 (patch)
treedf7967cd1cdd70732440740610e6940076623a39
parentabfc2a9abde676d63c32969d8fd8bfc3ef0eab8c (diff)
downloadpatches-cda982458501972c6e6a4927f96b21d286c93004.tar
patches-cda982458501972c6e6a4927f96b21d286c93004.tar.gz
gnu: Add wslay.
* gnu/packages/web.scm (wslay): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d3ab28bcfc..f6ae958ae3 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
+;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1095,6 +1096,36 @@ implementation that is simple, portable, flexible, lightweight, low level, and
high performance.")
(license license:bsd-3)))
+(define-public wslay
+ (package
+ (name "wslay")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tatsuhiro-t/wslay.git")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ak9a6hsanhys40yhv7c2gqkfghpm6jx36j1pnml8ajvgaky5q98"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("cunit" ,cunit) ; For tests.
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("python-sphinx" ,python-sphinx)))
+ (home-page "https://tatsuhiro-t.github.io/wslay/")
+ (synopsis "C WebSocket library")
+ (description "@code{Wslay} is an event-based C library for the WebSocket
+protocol version 13, described in RFC 6455. Besides a high-level API it
+provides callbacks for sending and receiving frames directly. @code{Wslay}
+only supports the data transfer part of WebSocket protocol and does not
+perform the opening handshake in HTTP.")
+ (license license:expat)))
+
(define-public libpsl
(package
(name "libpsl")