summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-01 15:39:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-03 12:34:31 +0100
commitc0fe2e1f03694cf7b29d418119c3ed0223973d59 (patch)
tree59db4f41700648a78df4d666696222ca6a5d89d6
parent82ca7b2a3a393a6341af64ab37324d622dbfe144 (diff)
downloadpatches-c0fe2e1f03694cf7b29d418119c3ed0223973d59.tar
patches-c0fe2e1f03694cf7b29d418119c3ed0223973d59.tar.gz
gnu: libx264: Update to 159-0.1771b55.
* gnu/packages/video.scm (libx264): Update to 159-0.1771b55. [source]: Change to GIT-FETCH. [version]: Use GIT-VERSION, and change from date-based identifier to the version defined in x264.h.
-rw-r--r--gnu/packages/video.scm99
1 files changed, 53 insertions, 46 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 871185027c..8c94f0e34a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
@@ -337,52 +337,59 @@ a shared library and encoder and decoder command-line executables.")
(license license:gpl2+)))
(define-public libx264
- (package
- (name "libx264")
- (version "20180810-2245")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://download.videolan.org/pub/x264/snapshots/"
- "x264-snapshot-" version "-stable.tar.bz2"))
- (sha256
- (base32
- "0f25f39imas9pcqm7lnaa0shhjmf42hdx7jxzcnvxc7qsb7lh1bv"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("nasm" ,nasm)))
- ;; TODO: Add gpac input
- (arguments
- `(#:tests? #f ;no check target
- #:configure-flags '("--enable-shared"
- ;; Don't build the command-line program. If we
- ;; want it later, we should do so in a different
- ;; package to avoid a circular dependency (the x264
- ;; program depends on ffmpeg and ffmpeg depends on
- ;; libx264).
- "--disable-cli"
-
- ;; On MIPS, we must pass "--disable-asm" or else
- ;; configure fails after printing: "You specified a
- ;; pre-MSA CPU in your CFLAGS. If you really want
- ;; to run on such a CPU, configure with
- ;; --disable-asm."
- ,@(if (string-prefix? "mips"
- (or (%current-target-system)
- (%current-system)))
- '("--disable-asm")
- '()))))
- (home-page "https://www.videolan.org/developers/x264.html")
- (synopsis "H.264 video coding library")
- (description "libx264 is an advanced encoding library for creating
+ ;; There are no tags in the repository, so we take the version number from
+ ;; the X264_BUILD variable defined in x264.h.
+ (let ((version "159")
+ (commit "1771b556ee45207f8711744ccbd5d42a3949b14c")
+ (revision "0"))
+ (package
+ (name "libx264")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://code.videolan.org/videolan/x264.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0kmi78gs5101d4df33il5bmjbns54nvdjsyn44xiw60lwsg11vwz"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("nasm" ,nasm)))
+ ;; TODO: Add gpac input
+ (arguments
+ `(#:tests? #f ;no check target
+ #:configure-flags '("--enable-shared"
+ ;; Don't build the command-line program. If we
+ ;; want it later, we should do so in a different
+ ;; package to avoid a circular dependency (the x264
+ ;; program depends on ffmpeg and ffmpeg depends on
+ ;; libx264).
+ "--disable-cli"
+
+ ;; On MIPS, we must pass "--disable-asm" or else
+ ;; configure fails after printing: "You specified a
+ ;; pre-MSA CPU in your CFLAGS. If you really want
+ ;; to run on such a CPU, configure with
+ ;; --disable-asm."
+ ,@(if (string-prefix? "mips"
+ (or (%current-target-system)
+ (%current-system)))
+ '("--disable-asm")
+ '()))))
+ (home-page "https://www.videolan.org/developers/x264.html")
+ (synopsis "H.264 video coding library")
+ (description "libx264 is an advanced encoding library for creating
H.264 (MPEG-4 AVC) video streams.")
- (license (list license:gpl2+ ;most files
- license:isc ;common/x86/x86inc.asm
- license:lgpl2.1+ ;extras/getopt.c
- license:bsd-3 ;extras/inttypes.h
- (license:non-copyleft ;extras/cl*.h
- "file://extras/cl.h"
- "See extras/cl.h in the distribution.")))))
+ (license (list license:gpl2+ ;most files
+ license:isc ;common/x86/x86inc.asm
+ license:lgpl2.1+ ;extras/getopt.c
+ license:bsd-3 ;extras/inttypes.h
+ (license:non-copyleft ;extras/cl*.h
+ "file://extras/cl.h"
+ "See extras/cl.h in the distribution."))))))
(define-public mkvtoolnix
(package