summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-02-02 14:34:10 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-02 15:31:01 +0100
commite9a36a74f355701f7b24a8cef9e70e47db68b5ea (patch)
treeb460c65560ec212d192e853619c751efacc044c3
parent21a519fac9a8f93d6c29def943514a31895d5029 (diff)
downloadpatches-e9a36a74f355701f7b24a8cef9e70e47db68b5ea.tar
patches-e9a36a74f355701f7b24a8cef9e70e47db68b5ea.tar.gz
gnu: Add cl-colors2.
* gnu/packages/lisp-xyz.scm (sbcl-cl-colors2, cl-colors2, ecl-cl-colors2): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 089a9b359c..bc4c2ce6f1 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9920,3 +9920,44 @@ easy to use so that you can quickly start testing.")
(define-public ecl-clunit2
(sbcl-package->ecl-package sbcl-clunit2))
+
+(define-public sbcl-cl-colors2
+ (let ((commit "795aedee593b095fecde574bd999b520dd03ed24")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-colors2")
+ (version (git-version "0.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://notabug.org/cage/cl-colors2.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hlyf4h5chkjdp9armla5w4kw5acikk159sym7y8c4jbjp9x47ih"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("clunit2" ,sbcl-clunit2)))
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("cl-ppcre" ,sbcl-cl-ppcre)))
+ (synopsis "Color library for Common Lisp")
+ (description
+ "This is a very simple color library for Common Lisp, providing:
+
+@itemize
+@item Types for representing colors in HSV and RGB spaces.
+@item Simple conversion functions between the above types (and also
+hexadecimal representation for RGB).
+@item Some predefined colors (currently X11 color names -- of course
+the library does not depend on X11).
+@end itemize\n")
+ (home-page "https://notabug.org/cage/cl-colors2")
+ (license license:boost1.0))))
+
+(define-public cl-colors2
+ (sbcl-package->cl-source-package sbcl-cl-colors2))
+
+(define-public ecl-cl-colors2
+ (sbcl-package->ecl-package sbcl-cl-colors2))