summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-01-06 01:36:00 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-01-31 23:37:13 -0500
commitd3e439e355284f136ff13eb3e6fffb4661552f3b (patch)
tree624e123167079a142ddacb1c3d7b00e73f7f3490
parent76f5428bc6b4b4d944be1c16f50d6e558416635f (diff)
downloadpatches-d3e439e355284f136ff13eb3e6fffb4661552f3b.tar
patches-d3e439e355284f136ff13eb3e6fffb4661552f3b.tar.gz
gnu: Add earlyoom-service-type.
* gnu/services/linux.scm: New file. * tests/services/linux.scm: Add test. * Makefile.am (SCM_TESTS): Register test. * doc/guix.texi (Linux Services): Add a new section and document the new service and its configuration.
-rw-r--r--Makefile.am1
-rw-r--r--doc/guix.texi69
-rw-r--r--gnu/services/linux.scm125
-rw-r--r--tests/services/linux.scm57
4 files changed, 251 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7474b7f375..c6a2e6cf6c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -426,6 +426,7 @@ SCM_TESTS = \
tests/scripts-build.scm \
tests/search-paths.scm \
tests/services.scm \
+ tests/services/linux.scm \
tests/sets.scm \
tests/size.scm \
tests/snix.scm \
diff --git a/doc/guix.texi b/doc/guix.texi
index 3141c4582f..956c25ba9e 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -48,7 +48,7 @@ Copyright @copyright{} 2017 humanitiesNerd@*
Copyright @copyright{} 2017 Christopher Allan Webber@*
Copyright @copyright{} 2017, 2018, 2019 Marius Bakke@*
Copyright @copyright{} 2017, 2019 Hartmut Goebel@*
-Copyright @copyright{} 2017, 2019 Maxim Cournoyer@*
+Copyright @copyright{} 2017, 2019, 2020 Maxim Cournoyer@*
Copyright @copyright{} 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice@*
Copyright @copyright{} 2017 George Clemmer@*
Copyright @copyright{} 2017 Andy Wingo@*
@@ -310,6 +310,7 @@ Services
* Version Control Services:: Providing remote access to Git repositories.
* Game Services:: Game servers.
* PAM Mount Service:: Service to mount volumes when logging in.
+* Linux Services:: Services tied to the Linux kernel.
* Miscellaneous Services:: Other services.
Defining Services
@@ -12084,6 +12085,7 @@ declaration.
* Game Services:: Game servers.
* PAM Mount Service:: Service to mount volumes when logging in.
* Guix Services:: Services relating specifically to Guix.
+* Linux Services:: Services tied to the Linux kernel.
* Miscellaneous Services:: Other services.
@end menu
@@ -25129,6 +25131,71 @@ list.
@end table
@end deftp
+@node Linux Services
+@subsubheading Linux Services
+
+@cindex oom
+@cindex out of memory killer
+@cindex earlyoom
+@cindex early out of memory daemon
+@subsection Early OOM Service
+
+@uref{https://github.com/rfjakob/earlyoom,Early OOM}, also known as
+Earlyoom, is a minimalist out of memory (OOM) daemon that runs in user
+space and provides a more responsive and configurable alternative to the
+in-kernel OOM killer. It is useful to prevent the system from becoming
+unresponsive when it runs out of memory.
+
+@deffn {Scheme Variable} earlyoom-service-type
+The service type for running @command{earlyoom}, the Early OOM daemon.
+Its value must be a @code{earlyoom-configuration} object, described
+below. The service can be instantiated in its default configuration
+with:
+
+@lisp
+(service earlyoom-service-type)
+@end lisp
+@end deffn
+
+@deftp {Data Type} earlyoom-configuration
+This is the configuration record for the @code{earlyoom-service-type}.
+
+@table @asis
+@item @code{earlyoom} (default: @var{earlyoom})
+The Earlyoom package to use.
+
+@item @code{minimum-available-memory} (default: @code{10})
+The threshold for the minimum @emph{available} memory, in percentages.
+
+@item @code{minimum-free-swap} (default: @code{10})
+The threshold for the minimum free swap memory, in percentages.
+
+@item @code{prefer-regexp} (default: @code{#f})
+A regular expression (as a string) to match the names of the processes
+that should be preferably killed.
+
+@item @code{avoid-regexp} (default: @code{#f})
+A regular expression (as a string) to match the names of the processes
+that should @emph{not} be killed.
+
+@item @code{memory-report-interval} (default: @code{0})
+The interval in seconds at which a memory report is printed. It is
+disabled by default.
+
+@item @code{ignore-positive-oom-score-adj?} (default: @code{#f})
+A boolean indicating whether the positive adjustments set in
+@file{/proc/*/oom_score_adj}.
+
+@item @code{show-debug-messages?} (default: @code{#f})
+A boolean indicating whether debug messages should be printed. The logs
+are saved at @file{/var/log/earlyoom.log}.
+
+@item @code{send-notification-command} (default: @code{#f})
+This can be used to provide a custom command used for sending
+notifications.
+@end table
+@end deftp
+
@node Miscellaneous Services
@subsection Miscellaneous Services
diff --git a/gnu/services/linux.scm b/gnu/services/linux.scm
new file mode 100644
index 0000000000..caa0326c31
--- /dev/null
+++ b/gnu/services/linux.scm
@@ -0,0 +1,125 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu services linux)
+ #:use-module (guix gexp)
+ #:use-module (guix records)
+ #:use-module (guix modules)
+ #:use-module (gnu services)
+ #:use-module (gnu services shepherd)
+ #:use-module (gnu packages linux)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26)
+ #:use-module (ice-9 match)
+ #:export (earlyoom-configuration
+ earlyoom-configuration?
+ earlyoom-configuration-earlyoom
+ earlyoom-configuration-minimum-available-memory
+ earlyoom-configuration-minimum-free-swap
+ earlyoom-configuration-prefer-regexp
+ earlyoom-configuration-avoid-regexp
+ earlyoom-configuration-memory-report-interval
+ earlyoom-configuration-ignore-positive-oom-score-adj?
+ earlyoom-configuration-show-debug-messages?
+ earlyoom-configuration-send-notification-command
+ earlyoom-service-type))
+
+
+;;;
+;;; Early OOM daemon.
+;;;
+
+(define-record-type* <earlyoom-configuration>
+ earlyoom-configuration make-earlyoom-configuration
+ earlyoom-configuration?
+ (earlyoom earlyoom-configuration-earlyoom
+ (default earlyoom))
+ (minimum-available-memory earlyoom-configuration-minimum-available-memory
+ (default 10)) ; in percent
+ (minimum-free-swap earlyoom-configuration-minimum-free-swap
+ (default 10)) ; in percent
+ (prefer-regexp earlyoom-configuration-prefer-regexp ; <string>
+ (default #f))
+ (avoid-regexp earlyoom-configuration-avoid-regexp ; <string>
+ (default #f))
+ (memory-report-interval earlyoom-configuration-memory-report-interval
+ (default 0)) ; in seconds; 0 means disabled
+ (ignore-positive-oom-score-adj?
+ earlyoom-configuration-ignore-positive-oom-score-adj? (default #f))
+ (run-with-higher-priority? earlyoom-configuration-run-with-higher-priority?
+ (default #f))
+ (show-debug-messages? earlyoom-configuration-show-debug-messages?
+ (default #f))
+ (send-notification-command
+ earlyoom-configuration-send-notification-command ; <string>
+ (default #f)))
+
+(define (earlyoom-configuration->command-line-args config)
+ "Translate a <earlyoom-configuration> object to its command line arguments
+representation."
+ (match config
+ (($ <earlyoom-configuration> earlyoom minimum-available-memory
+ minimum-free-swap prefer-regexp avoid-regexp
+ memory-report-interval
+ ignore-positive-oom-score-adj?
+ run-with-higher-priority? show-debug-messages?
+ send-notification-command)
+ `(,(file-append earlyoom "/bin/earlyoom")
+ ,@(if minimum-available-memory
+ (list "-m" (format #f "~s" minimum-available-memory))
+ '())
+ ,@(if minimum-free-swap
+ (list "-s" (format #f "~s" minimum-free-swap))
+ '())
+ ,@(if prefer-regexp
+ (list "--prefer" prefer-regexp)
+ '())
+ ,@(if avoid-regexp
+ (list "--avoid" avoid-regexp)
+ '())
+ "-r" ,(format #f "~s" memory-report-interval)
+ ,@(if ignore-positive-oom-score-adj?
+ (list "-i")
+ '())
+ ,@(if run-with-higher-priority?
+ (list "-p")
+ '())
+ ,@(if show-debug-messages?
+ (list "-d")
+ '())
+ ,@(if send-notification-command
+ (list "-N" send-notification-command)
+ '())))))
+
+(define (earlyoom-shepherd-service config)
+ (shepherd-service
+ (documentation "Run the Early OOM daemon.")
+ (provision '(earlyoom))
+ (start #~(make-forkexec-constructor
+ '#$(earlyoom-configuration->command-line-args config)
+ #:log-file "/var/log/earlyoom.log"))
+ (stop #~(make-kill-destructor))))
+
+(define earlyoom-service-type
+ (service-type
+ (name 'earlyoom)
+ (default-value (earlyoom-configuration))
+ (extensions
+ (list (service-extension shepherd-root-service-type
+ (compose list earlyoom-shepherd-service))))
+ (description "Run @command{earlyoom}, the Early OOM daemon.")))
diff --git a/tests/services/linux.scm b/tests/services/linux.scm
new file mode 100644
index 0000000000..8ad119c49f
--- /dev/null
+++ b/tests/services/linux.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (tests services linux)
+ #:use-module (ice-9 match)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu services linux)
+ #:use-module (guix gexp)
+ #:use-module (srfi srfi-64))
+
+;;; Tests for the (gnu services linux) module.
+
+(test-begin "linux-services")
+
+
+;;;
+;;; Early OOM daemon.
+;;;
+
+(define earlyoom-configuration->command-line-args
+ (@@ (gnu services linux) earlyoom-configuration->command-line-args))
+
+(define %earlyoom-configuration-sample
+ (earlyoom-configuration
+ (minimum-available-memory 10)
+ (minimum-free-swap 20)
+ (prefer-regexp "icecat")
+ (avoid-regexp "guix-daemon")
+ (memory-report-interval 60)
+ (ignore-positive-oom-score-adj? #f)
+ (run-with-higher-priority? #t)
+ (show-debug-messages? #f)
+ (send-notification-command "python \"/some/path/notify-all-users.py\"")))
+
+(test-equal "earlyoom-configuration->command-line-args"
+ (list (file-append earlyoom "/bin/earlyoom")
+ "-m" "10" "-s" "20" "--prefer" "icecat"
+ "--avoid" "guix-daemon" "-r" "60" "-p"
+ "-N" "python \"/some/path/notify-all-users.py\"")
+ (earlyoom-configuration->command-line-args %earlyoom-configuration-sample))
+
+(test-end "linux-services")