summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-02-02 13:56:50 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-02 15:29:54 +0100
commit95abaafb7438450211aa56d96bcf6995acd2aedf (patch)
tree5662ee66a1485d9756604f48ae9cf73b5708ba35
parent8baaf51f0a6891cc2fb34928dab2337b627218c5 (diff)
downloadpatches-95abaafb7438450211aa56d96bcf6995acd2aedf.tar
patches-95abaafb7438450211aa56d96bcf6995acd2aedf.tar.gz
gnu: Add cl-lex.
* gnu/packages/lisp-xyz.scm (sbcl-cl-lex, cl-lex, ecl-cl-lex): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 4cb2982f40..f3d03ffc2c 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9859,3 +9859,35 @@ from the one running the Lisp program by using a TCP connection.")))
(define-public cl-ltk-remote
(sbcl-package->cl-source-package sbcl-ltk-remote))
+
+(define-public sbcl-cl-lex
+ (let ((commit "f2dbbe25ef553005fb402d9a6203180c3fa1093b")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-lex")
+ (version (git-version "1.1.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/djr7C4/cl-lex.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kg50f76bfpfxcv4dfivq1n9a0xlsra2ajb0vd68lxwgbidgyc2y"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cl-ppcre" ,sbcl-cl-ppcre)))
+ (synopsis "Common Lisp macros for generating lexical analyzers")
+ (description
+ "This is a Common Lisp library providing a set of macros for generating
+lexical analyzers automatically. The lexers generated using @code{cl-lex} can
+be used with @code{cl-yacc}.")
+ (home-page "https://github.com/djr7C4/cl-lex")
+ (license license:gpl3))))
+
+(define-public cl-lex
+ (sbcl-package->cl-source-package sbcl-cl-lex))
+
+(define-public ecl-cl-lex
+ (sbcl-package->ecl-package sbcl-cl-lex))