summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-01-06 20:19:06 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-01-31 23:41:49 -0500
commit4690e3a4ec41e4e3dc46c6f7045bea978533d8f3 (patch)
tree4119cf1565e4ee9aae6ece1c117d12580a3377c7
parentd3e439e355284f136ff13eb3e6fffb4661552f3b (diff)
downloadpatches-4690e3a4ec41e4e3dc46c6f7045bea978533d8f3.tar
patches-4690e3a4ec41e4e3dc46c6f7045bea978533d8f3.tar.gz
gnu: arc-theme: Placate Inkscape.
This gets rid of Inkscape's warnings printed during the build when HOME is not set to a writable directory. * gnu/packages/gnome.scm (arc-theme)[phases]{set-home}: New phase.
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e843bdfe08..e19caf67f7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2019 Jonathan Frederickson <jonathan@terracrypt.net>
-;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2019, 2020 Raghav Gururajan <raghavgururajan@disroot.org>
@@ -8302,7 +8302,11 @@ functionality and behavior.")
(modify-phases %standard-phases
;; autogen.sh calls configure at the end of the script.
(replace 'bootstrap
- (lambda _ (invoke "autoreconf" "-vfi"))))))
+ (lambda _ (invoke "autoreconf" "-vfi")))
+ (add-before 'build 'set-home ;placate Inkscape
+ (lambda _
+ (setenv "HOME" (getcwd))
+ #t)))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)